Bug 134967 - X Server segfaults on startup on dual-head Radeon 9200
X Server segfaults on startup on dual-head Radeon 9200
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-07 11:49 EDT by Jay Fenlason
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 11:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration file for X server (3.55 KB, text/plain)
2004-10-07 11:50 EDT, Jay Fenlason
no flags Details
Log of the X server failing to start (45.08 KB, text/plain)
2004-10-07 11:51 EDT, Jay Fenlason
no flags Details

  None (edit)
Description Jay Fenlason 2004-10-07 11:49:35 EDT
ssia


Version-Release number of selected component (if applicable):xorg-x11-6.8.1-4


How reproducible:Always


Steps to Reproduce:
1.Install attached xorg.conf in /etc/X11
2.run xinit
3.
  
Actual results:X server fails with a signal 11


Expected results:X server should start


Additional info:
Comment 1 Jay Fenlason 2004-10-07 11:50:45 EDT
Created attachment 104902 [details]
Configuration file for X server
Comment 2 Jay Fenlason 2004-10-07 11:51:26 EDT
Created attachment 104903 [details]
Log of the X server failing to start
Comment 4 Kristian Høgsberg 2004-10-15 16:31:48 EDT
I have the box in my cube now, the bug is caused by missing "Screen 0"
and "Screen 1" lines in the Device sections.  Can be worked around by
adding those lines.  The crash is in xf86InitOrigins().
Comment 5 Kristian Høgsberg 2004-10-18 22:31:08 EDT
There's a fix in xorg-x11-6.8.1-9, please update and see if it solves
the problem.

Thanks,
Kristian
Comment 6 Jay Fenlason 2005-10-24 11:48:45 EDT
This appears to work in fc4. 

Note You need to log in before you can comment on or make changes to this bug.