Bug 134978 - DeprecationWarning messages issued during normal operation.
Summary: DeprecationWarning messages issued during normal operation.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-07 17:14 UTC by Richard Ryniker
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 22:49:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Ryniker 2004-10-07 17:14:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
Following was generated by the actions: stop sendmail; do not start
sendmail automatically at boot.

[root@r400x ryniker]# /usr/sbin/system-config-services 
/usr/sbin/system-config-services:187: DeprecationWarning: 
  self.btnStart = self.tbrSave.append_item(_("Start"), _("Start"),
None, icon, self.on_btnStart_clicked, None)
/usr/sbin/system-config-services:191: DeprecationWarning: 
  self.btnStop = self.tbrSave.append_item(_("Stop"), _("Stop"), None,
icon, self.on_btnStop_clicked, None)
/usr/sbin/system-config-services:195: DeprecationWarning: 
  self.btnRestart = self.tbrSave.append_item(_("Restart"),
_("Restart"), None, icon, self.on_btnRestart_clicked, None)
/usr/sbin/system-config-services:197: DeprecationWarning: 
  self.tbrSave.insert_space(3)
/usr/sbin/system-config-services:201: DeprecationWarning: 
  self.btnSave = self.tbrSave.append_item(_("_Save"), _("Save"), None,
icon, self.on_mnuSave_clicked, None)
/usr/sbin/system-config-services:206: DeprecationWarning: 
  self.btnRevert = self.tbrSave.append_item(_("_Revert"), _("Revert"),
None, icon, self.on_mnuRevert_clicked, None)
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainiteration is deprecated, use
gtk.main_iteration instead
  self.warn(message, DeprecationWarning)
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead
  self.warn(message, DeprecationWarning)
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainquit is deprecated, use gtk.main_quit
instead
  self.warn(message, DeprecationWarning)
[root@r400x ryniker]# 


Version-Release number of selected component (if applicable):
system-config-services-0.8.8-8

How reproducible:
Didn't try


Actual Results:  The intended configuration changes were achieved.

Expected Results:  Same, without deprecation warnings.

Additional info:

Comment 1 Nils Philippsen 2004-10-08 09:32:11 UTC
All the gtk.main* DeprecationWarnings are easily fixable, I'll do it
right now. Unfortunately fixing the other DeprecationWarnings
(toolbar/gtk.ItemFactory related) changes translatable string so this
is something I want to defer until after FC3.

Comment 2 Nils Philippsen 2004-10-08 09:47:15 UTC
The 0.8.11-1 package which fixes the gtk.main*() related warnings has
just been built.

Comment 3 Matthew Miller 2005-03-16 16:50:41 UTC
Still getting this in the devel tree system-config-services-0.8.19-1:


/usr/sbin/system-config-services:195: DeprecationWarning:
  self.btnStart = self.tbrSave.append_item(_("Start"), _("Start"), None, icon,
self.on_btnStart_clicked, None)
/usr/sbin/system-config-services:199: DeprecationWarning:
  self.btnStop = self.tbrSave.append_item(_("Stop"), _("Stop"), None, icon,
self.on_btnStop_clicked, None)
/usr/sbin/system-config-services:203: DeprecationWarning:
  self.btnRestart = self.tbrSave.append_item(_("Restart"), _("Restart"), None,
icon, self.on_btnRestart_clicked, None)
/usr/sbin/system-config-services:205: DeprecationWarning:
  self.tbrSave.insert_space(3)
/usr/sbin/system-config-services:209: DeprecationWarning:
  self.btnSave = self.tbrSave.append_item(_("_Save"), _("Save"), None, icon,
self.on_mnuSave_clicked, None)
/usr/sbin/system-config-services:214: DeprecationWarning:
  self.btnRevert = self.tbrSave.append_item(_("_Revert"), _("Revert"), None,
icon, self.on_mnuRevert_clicked, None)

(Also, not arch-specific)


Comment 4 Nils Philippsen 2005-03-18 15:20:52 UTC
Supposed to be fixed in system-config-services-0.8.20-0.fc3.1 which should hit
mirrors soon. Please verify.


Note You need to log in before you can comment on or make changes to this bug.