Bug 134999 - Stops booting at "Setting kernel parameters", does not start X
Stops booting at "Setting kernel parameters", does not start X
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 16:46 EDT by Andrew
Modified: 2015-01-04 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-13 00:03:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew 2004-10-07 16:46:08 EDT
Description of problem:
HP d220m computer stops booting at the prompt "Setting kernel
parameters"; X does not load to start Red Hat Graphical Boot (rhgb)

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.598, but kernel-2.6.8-1.541 is NOT affected

How reproducible:
Every time

Steps to Reproduce:
1. Boot computer
2. Screen displays "Setting kernel parameters" and blanks
3. 
  
Actual results:
Flashing cursor appears, X never starts, RHGB never starts

Expected results:
Machine boots as with kernel-2.6.8-1.541


Additional info:

Machine is HP d220m, 2.4GHz, 768MB RAM with HP/AmiBIOS 1.12 BIOS from
June 2004

kernel: /vmlinuz-2.6.8-1.598 ro root=LABEL=/ vga=791 rhgb quiet

lspci says:
00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM
Controller/Host-Hub Interface (rev 03)
00:02.0 VGA compatible controller: Intel Corp.
82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) LPC
Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
03:0a.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T
(rev 01)
Comment 1 Bill Nottingham 2004-10-07 17:51:00 EDT
That's where the current time is read from the hardware clock.
Comment 2 Andrew 2004-10-11 15:12:35 EDT
Same thing with kernel-2.6.8-1.603 from rawhide.  On bootup I get:

irq 9: nobody cared! (screaming interrupt?)
irq 9: Please try booting with acpi=off and report a bug
handlers:
[<021f277b>] (acpi_irq+0x0/0x14)
Disabling IRQ #9
audit(1097490531.438:0): initialized
Red Hat nash version 4.1.14 starting
INIT: version 2.85 booting
Setting default font (latarcyrheb-sun16):              [OK]

                      Welcome to Fedora Core
                   Pres 'I' to enter interactive startup.
Starting udev:                                         [OK]
Initializing hardware...  storage network audio done   [OK]
Configuring kernel parameters:  _

...and the underscore blinks there on TTY1.
The screen blanks and then goes to a "black" display with only the
cursor in the top left corner, and X does not start.

I have tried acpi=off on 2.6.8-1.603, but that only removes the first
5 lines above, and the kernel starts booting with "audit(...".  Stops
in the same place too.
The last kernel that I can boot is 2.6.8-1.541.  What else can I do to
help?
Comment 3 Dierck Hillmann 2004-10-12 10:32:43 EDT
I get this bug with both 2.6.8.1-1.541 and 2.6.8.1-1.603. But I didn't
install test3, I was using test2 but updated with up2date (some
packages) and with "yum update" the other packages. So, I would thing
it's not a kernel problem, as I could boot with both 541 and 603
before these updates.

Well, the system not really hangs, as I can cancel the process with
Ctrl+C, but then the filesystem is mounted readonly and therefore the
system won't boot correctly. 

Well, and I just noticed my WinXP clock showed an hour later the last
time I booted windows and in the meantime I just tried once more to
boot Fedora. Strange... Maybe it's a clock problem.

I can't tell whether X would load, cause my system uses nvidia-drivers
and I had to load those via modprobe nvidia in rc.local and therefore
the moduls is loaded at the end of the booting process. 
Comment 4 Andrew 2004-10-12 13:14:50 EDT
OK, kernel-2.6.8-1.607 from Rawhide did the trick!  Booted normally
(without any intervention).

Will keep monitoring as new kernels are released and update this bug
report if I still have issues.
Comment 5 Need Real Name 2004-11-15 16:46:40 EST
15 Nov 04

Having identical problems; this time with Fedora Core 3 release.
kernel is 2.6.9-1.667

Hardware is IBM Thinkpad 240.

System boots fine -- exactly the same hard drive -- on a Toshiba S501
5101.
Comment 6 Need Real Name 2004-11-22 13:40:17 EST
Aha.  FIXED.  

1.  The new rhgb release this weekend (20 Nov) fixed the problem.

2.  A workaround is to intercept the GRUB splash screen (at least in
Fedore Core 3), edit the second (of three) lines of boot parameters --
delete the command to start rhgb (very last of the line).  I had to do
this in order to bring a system up and download the fix (see 1. above).


Dan's got finger on the right thing.  rhgb is trying to start the X
server at this point so you get the quichy GUI interface to the init
sequence (why that's necessary isn't entirely clear to me).  When X
doesn't start, things hang.  The new rhgb release clears this -- if X
doesn't start it goes on without.  

In my case the reason X was hanging was that I was booting in a
different machine than the one I installed on -- different video
driver.  And rhgb is trying to start X on the installed video driver
... before kudzu starts up and fixes the config.


Comment 7 Dave Jones 2004-12-07 00:43:02 EST
is this one fixed now with the latest errata bits ?

Note You need to log in before you can comment on or make changes to this bug.