Bug 1349999 - [RH Ceph 2.0]: ceph-deploy handle package split for ceph-mon and ceph-osd
Summary: [RH Ceph 2.0]: ceph-deploy handle package split for ceph-mon and ceph-osd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 2.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: 2.1
Assignee: Ken Dreyer (Red Hat)
QA Contact: Vasu Kulkarni
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-24 18:52 UTC by Vasu Kulkarni
Modified: 2017-12-13 00:28 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-deploy-1.5.36-20.el7cp Ubuntu: ceph-deploy_1.5.36-20redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-22 19:27:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2016:2815 normal SHIPPED_LIVE Moderate: Red Hat Ceph Storage security, bug fix, and enhancement update 2017-03-22 02:06:33 UTC

Description Vasu Kulkarni 2016-06-24 18:52:54 UTC
Description of problem:

for ubuntu the package split has happened for ceph-mon and ceph-osd, we should handle this in ceph-deploy so that install can work

ubuntu@magna114:~$ sudo ceph-deploy install --no-adjust-repos magna114
[ceph_deploy.conf][DEBUG ] found configuration file at: /home/ubuntu/.cephdeploy.conf
[ceph_deploy.cli][INFO  ] Invoked (1.5.33): /usr/bin/ceph-deploy install --no-adjust-repos magna114
[ceph_deploy.cli][INFO  ] ceph-deploy options:
[ceph_deploy.cli][INFO  ]  verbose                       : False
[ceph_deploy.cli][INFO  ]  testing                       : None
[ceph_deploy.cli][INFO  ]  cd_conf                       : <ceph_deploy.conf.cephdeploy.Conf instance at 0x7f89d1dd6680>
[ceph_deploy.cli][INFO  ]  cluster                       : ceph
[ceph_deploy.cli][INFO  ]  dev_commit                    : None
[ceph_deploy.cli][INFO  ]  install_mds                   : False
[ceph_deploy.cli][INFO  ]  stable                        : None
[ceph_deploy.cli][INFO  ]  default_release               : False
[ceph_deploy.cli][INFO  ]  username                      : None
[ceph_deploy.cli][INFO  ]  adjust_repos                  : False
[ceph_deploy.cli][INFO  ]  func                          : <function install at 0x7f89d2229320>
[ceph_deploy.cli][INFO  ]  install_all                   : False
[ceph_deploy.cli][INFO  ]  repo                          : False
[ceph_deploy.cli][INFO  ]  host                          : ['magna114']
[ceph_deploy.cli][INFO  ]  install_rgw                   : False
[ceph_deploy.cli][INFO  ]  install_tests                 : False
[ceph_deploy.cli][INFO  ]  repo_url                      : None
[ceph_deploy.cli][INFO  ]  ceph_conf                     : None
[ceph_deploy.cli][INFO  ]  install_osd                   : False
[ceph_deploy.cli][INFO  ]  version_kind                  : stable
[ceph_deploy.cli][INFO  ]  install_common                : False
[ceph_deploy.cli][INFO  ]  overwrite_conf                : False
[ceph_deploy.cli][INFO  ]  quiet                         : False
[ceph_deploy.cli][INFO  ]  dev                           : master
[ceph_deploy.cli][INFO  ]  local_mirror                  : None
[ceph_deploy.cli][INFO  ]  release                       : None
[ceph_deploy.cli][INFO  ]  install_mon                   : False
[ceph_deploy.cli][INFO  ]  gpg_url                       : None
[ceph_deploy.install][DEBUG ] Installing stable version jewel on cluster ceph hosts magna114
[ceph_deploy.install][DEBUG ] Detecting platform for host magna114 ...
[magna114][DEBUG ] connected to host: magna114 
[magna114][DEBUG ] detect platform information from remote host
[magna114][DEBUG ] detect machine type
[ceph_deploy.install][INFO  ] Distro info: Ubuntu 16.04 xenial
[magna114][INFO  ] installing Ceph on magna114
[magna114][INFO  ] Running command: env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q --no-install-recommends install ca-certificates apt-transport-https
[magna114][DEBUG ] Reading package lists...
[magna114][DEBUG ] Building dependency tree...
[magna114][DEBUG ] Reading state information...
[magna114][DEBUG ] ca-certificates is already the newest version (20160104ubuntu1).
[magna114][DEBUG ] apt-transport-https is already the newest version (1.2.12~ubuntu16.04.1).
[magna114][DEBUG ] The following packages were automatically installed and are no longer required:
[magna114][DEBUG ]   libboost-iostreams1.58.0 libboost-program-options1.58.0
[magna114][DEBUG ]   libboost-random1.58.0 libboost-regex1.58.0 libcephfs1 liblttng-ust0
[magna114][DEBUG ]   librados2 librbd1 librgw2 python-cephfs python-chardet
[magna114][DEBUG ]   python-ndg-httpsclient python-rados python-rbd python-requests
[magna114][DEBUG ]   python-urllib3
[magna114][DEBUG ] Use 'sudo apt autoremove' to remove them.
[magna114][DEBUG ] 0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
[magna114][INFO  ] Running command: env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q update
[magna114][DEBUG ] Hit:1 http://download.eng.bos.redhat.com/rcm-guest/ceph-drops/2.0.0/latest-Ceph-2-Ubuntu/MON xenial InRelease
[magna114][DEBUG ] Hit:2 http://download.eng.bos.redhat.com/rcm-guest/ceph-drops/2.0.0/latest-Ceph-2-Ubuntu/OSD xenial InRelease
[magna114][DEBUG ] Hit:3 http://security.ubuntu.com/ubuntu xenial-security InRelease
[magna114][DEBUG ] Hit:4 http://download.eng.bos.redhat.com/rcm-guest/ceph-drops/2.0.0/latest-Ceph-2-Ubuntu/Tools xenial InRelease
[magna114][DEBUG ] Hit:5 http://archive.ubuntu.com/ubuntu xenial InRelease
[magna114][DEBUG ] Hit:6 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
[magna114][DEBUG ] Hit:7 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
[magna114][DEBUG ] Reading package lists...
[magna114][INFO  ] Running command: env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q --no-install-recommends install -o Dpkg::Options::=--force-confnew ceph ceph-mds radosgw
[magna114][DEBUG ] Reading package lists...
[magna114][DEBUG ] Building dependency tree...
[magna114][DEBUG ] Reading state information...
[magna114][DEBUG ] Some packages could not be installed. This may mean that you have
[magna114][DEBUG ] requested an impossible situation or if you are using the unstable
[magna114][DEBUG ] distribution that some required packages have not yet been created
[magna114][DEBUG ] or been moved out of Incoming.
[magna114][DEBUG ] The following information may help to resolve the situation:
[magna114][DEBUG ] 
[magna114][DEBUG ] The following packages have unmet dependencies:
[magna114][DEBUG ]  ceph : Depends: ceph-common (= 10.2.0-0ubuntu0.16.04.2) but 10.2.2-5redhat1xenial is to be installed
[magna114][WARNIN] E: Unable to correct problems, you have held broken packages.
[magna114][ERROR ] RuntimeError: command returned non-zero exit status: 100
[ceph_deploy][ERROR ] RuntimeError: Failed to execute command: env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q --no-install-recommends install -o Dpkg::Options::=--force-confnew ceph ceph-mds radosgw

Comment 2 Christina Meno 2016-06-27 17:00:56 UTC
Vasu, What is the impact to downstream here?

Comment 4 Ken Dreyer (Red Hat) 2016-06-28 16:37:03 UTC
Discussed today in scrub call: Important to fix, but won't block 2.0 GA

Comment 13 Vasu Kulkarni 2016-11-03 00:24:16 UTC
Verified with smoke.

Comment 15 errata-xmlrpc 2016-11-22 19:27:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2016-2815.html


Note You need to log in before you can comment on or make changes to this bug.