Bug 135 - xntpd3-5.93-2 /etc/ntp.conf bug
xntpd3-5.93-2 /etc/ntp.conf bug
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xntp3 (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-19 14:18 EST by nelson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-11-22 14:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nelson 1998-11-19 14:18:32 EST
I believe that the /etc/ntp.conf in xntpd3-5.93-2 is
incorrect. The problem is the undisciplined local clock
setup:

server        127.127.1.0     # local clock
fudge 127.127.1.0 stratum 0

If the user runs NTP without configuration, this is OK. But
if he or she sets up a few NTP servers and forgets to delete
this local server, then it breaks - because this clock is at
stratum 0 it *is* used preferentially. At least, it looks
that way when I tested it.

I'm not sure how to fix it. Leave out the local clock
entirely (it's not clear it's necessary), or maybe set it at
stratum 14 so it's only used as a last resort. I'm not an
expert with NTP, though, so testing a fix would be a good
idea.

I'm a big believer in NTP. But people tend not to set it up
because the NTP docs are awful. It'd be nice if the RedHat
configure / install stuff made it easy for users to use NTP.
Comment 1 Jeff Johnson 1998-11-22 14:46:59 EST
Changed ntp.conf to say
	fudge 127.127.1.0 stratum 10

(Fixed in dist-6.0/xntp3-5.93-6.src.rpm)
Comment 2 nelson 1999-12-06 20:46:59 EST
I recently did a survey of the NTP network, and found that there are at least
250 Red Hat hosts out there that still have this misconfiguration. Turns out
this accounts for more than half of the bad stratum 1 clocks out there on the
Internet. The bug has been fixed in new versions, so all will be better in the
future, but it's interesting how long these problems persist.

My discussion of this will be online at
  http://nelson.www.media.mit.edu/people/nelson/research/ntp-survey99/

Note You need to log in before you can comment on or make changes to this bug.