Bug 1350 - Lpd daemon waits for ever
Lpd daemon waits for ever
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-26 04:15 EST by veijo.ryhanen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-02 17:35:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description veijo.ryhanen 1999-02-26 04:15:00 EST
Everything works fine with lpd until today:

I tried to print one small text page from RH5.2+Netscape
communicator.
After that I went to watch HPLaserjet4+ Postscript printer.
It was run
out of paper. Instead of that, printers display panel said:
"Insert more
A4 papers". I put more paper and found that other one page
print
work from Windows NT came out immediately. (via NT-shared
printer)
My direct IP-protocol printwork did not came out.

I tried to print several times, until I found that stupid
lpd -daemon
is waiting for printer to come back on-line again:

root# lpq -P possu
rmk4146.novogroup.com: waiting for 192.194.127.91 to come up
Rank   Owner      Job  Files
Total Size
1st    root       29   (standard input)
12105 bytes

But it was online and ready ALL the TIME ! Printers display
panel said: "Ready"

Command: lprm -P possu  does not work. It just wait that I
pressed Ctrl+C
to get my prompt back.

I kill lpd -daemon and remove cfA029Aa00592 and
dfA029Aa00592 -types files
from /var/spool/lpd/possu and restarted lpd. Nothing helps.

I had to uninstall possu printer from RH5.2 print system
manager panel and
I removed possu -directory from /var/spool/lpd/.

I reinstalled printer. This time I used /var/spool/lpd/lp
-directory.

Postscript test page from "print system manager" -window did
not came out.

lpq shows now:
2lpd# lpq
rmk4146.novogroup.com: waiting for 192.194.127.91 to come up
Rank   Owner      Job  Files
Total Size
1st    root       0     ...
16618 bytes
2nd    root       1     ...
16618 bytes

After several minutes pause lpd print out error message:
"connection to 192.194.127.91 is down"

But it WAS NOT DOWN! My friend print small work from Windows
NT at
the same time.
I reboot my computer to Windows NT4.0 and print from there.
Everything
works fine!
After that I rebooted back to Linux. Keyboard did not work
at this time.
(That will happen quite often with Compaq Deskpro 400MHz P2,
ATX-mother-
board). So I rebooted Linux with power switch, because
Ctrl+Alt+Del does
not work, as it happens sometimes.

When I was logged in Linux again and check lpq it looks like
this:
rmk4146.novogroup.com: waiting for 192.194.127.91 to come up
Rank   Owner      Job  Files
Total Size
1st    root       0     ...
16618 bytes
2nd    root       1     ...
16618 bytes

This means that I have to reboot to WindowsNT every time I
want print
something. This is _very_ irritating.

My /etc/printcap looks like this:
##PRINTTOOL3## REMOTE POSTSCRIPT 600x600 a4 {} PostScript
Default 1
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :rm=192.194.127.91:\
        :rp=:\
        :if=/var/spool/lpd/lp/filter:


(possu is nickname for postscript here in Finland.)
Comment 1 David Lawrence 1999-03-02 17:35:59 EST
I was unable to replicate this problem in our testlab.

Note You need to log in before you can comment on or make changes to this bug.