Bug 1350050 - ICAClient Citrix reciever cores loading /lib64/libjavascriptcoregtk-1.0.so.0
Summary: ICAClient Citrix reciever cores loading /lib64/libjavascriptcoregtk-1.0.so.0
Keywords:
Status: CLOSED DUPLICATE of bug 1349318
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-24 21:52 UTC by Brian Millett
Modified: 2016-06-24 21:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-24 21:54:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Brian Millett 2016-06-24 21:52:15 UTC
Description of problem:

run /opt/Citrix/ICAClient/selfservice --icaroot /opt/Citrix/ICAClient
causes a sig fault

Version-Release number of selected component (if applicable):

webkitgtk-2.4.11-1.fc24.x86_64
ICAClient-13.3.0.344519-0.x86_64

How reproducible:

every time

Steps to Reproduce:
1.launch
2.cores
3.

Actual results:
cores

Expected results:

Citrix client to appear

Additional info:

Running gdb to launch provides the following backtrace
Thread 2 "selfservice" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffe45c0700 (LWP 5407)]
0x00007fffe9e35ee8 in WTF::String::isolatedCopy() const ()
   from /lib64/libjavascriptcoregtk-1.0.so.0
(gdb) bt
#0  0x00007fffe9e35ee8 in WTF::String::isolatedCopy() const ()
   from /lib64/libjavascriptcoregtk-1.0.so.0
#1  0x00007fffe9980664 in OpaqueJSString::string() const ()
   from /lib64/libjavascriptcoregtk-1.0.so.0
#2  0x00007fffe9975452 in JSObjectMakeFunction () from /lib64/libjavascriptcoregtk-1.0.so.0
#3  0x000000000042c07a in ?? ()
#4  0x000000000041de77 in SsUI::window_object_cleared_cb(_WebKitWebView*, _WebKitWebFrame*, void*, void*, char*) ()
#5  0x00007ffff47fe3e8 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#6  0x00007ffff48104a2 in signal_emit_unlocked_R () from /lib64/libgobject-2.0.so.0
#7  0x00007ffff481912d in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#8  0x00007ffff48199ab in g_signal_emit_by_name () from /lib64/libgobject-2.0.so.0
#9  0x00007fffea59bc70 in WebKit::FrameLoaderClient::dispatchDidClearWindowObjectInWorld(WebCore::DOMWrapperWorld&) () from /lib64/libwebkitgtk-1.0.so.0
#10 0x00007fffead19a44 in WebCore::FrameLoader::dispatchDidClearWindowObjectInWorld(WebCore::DOMWrapperWorld&) () from /lib64/libwebkitgtk-1.0.so.0
#11 0x00007fffea7953bb in WebCore::ScriptController::initScript(WebCore::DOMWrapperWorld&) ()
   from /lib64/libwebkitgtk-1.0.so.0
#12 0x00007fffea795b9b in WebCore::ScriptController::evaluateInWorld(WebCore::ScriptSourceCode const&, WebCore::DOMWrapperWorld&) () from /lib64/libwebkitgtk-1.0.so.0
#13 0x00007fffea795cbb in WebCore::ScriptController::evaluate(WebCore::ScriptSourceCode const&) ()
   from /lib64/libwebkitgtk-1.0.so.0
#14 0x00007fffea98e531 in WebCore::ScriptElement::executeScript(WebCore::ScriptSourceCode const&)
    () from /lib64/libwebkitgtk-1.0.so.0
#15 0x00007fffeab9d6a1 in WebCore::HTMLScriptRunner::executePendingScriptAndDispatchEvent(WebCore::PendingScript&) () from /lib64/libwebkitgtk-1.0.so.0
#16 0x00007fffeab9db96 in WebCore::HTMLScriptRunner::executeParsingBlockingScript() ()
   from /lib64/libwebkitgtk-1.0.so.0
#17 0x00007fffeab9df3f in WebCore::HTMLScriptRunner::executeParsingBlockingScripts() ()
   from /lib64/libwebkitgtk-1.0.so.0
#18 0x00007fffeab89485 in WebCore::HTMLDocumentParser::notifyFinished(WebCore::CachedResource*) ()
   from /lib64/libwebkitgtk-1.0.so.0
#19 0x00007fffeacedab7 in WebCore::CachedResource::checkNotify() ()
   from /lib64/libwebkitgtk-1.0.so.0
#20 0x00007fffead613ab in WebCore::SubresourceLoader::didFinishLoading(double) ()
   from /lib64/libwebkitgtk-1.0.so.0

Comment 1 Kevin Fenzi 2016-06-24 21:54:27 UTC

*** This bug has been marked as a duplicate of bug 1349318 ***


Note You need to log in before you can comment on or make changes to this bug.