Bug 1350174 - KASLR disabled: 'kaslr' not on cmdline (hibernation selected).
KASLR disabled: 'kaslr' not on cmdline (hibernation selected).
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-26 05:25 EDT by deadrat
Modified: 2016-09-15 16:55 EDT (History)
34 users (show)

See Also:
Fixed In Version: kernel-4.7.3-200.fc24
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 18:22:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (1.62 MB, image/jpeg)
2016-06-26 05:25 EDT, deadrat
no flags Details

  None (edit)
Description deadrat 2016-06-26 05:25:21 EDT
Created attachment 1172479 [details]
screenshot

Description of problem:
A warning/error during startup, right after the GRUB screen and before dracut. 

Version-Release number of selected component (if applicable):
Fedora rawhide ( Linux machine 4.7.0-0.rc4.git1.1.fc25.x86_64 #1 SMP Tue Jun 21 15:11:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux )



How reproducible:
Happens everytime on boot

Steps to Reproduce:

1. Install Fedora rawhide. ( I installed Fedora-Workstation-Live-x86_64-Rawhide-20160623.n.0.iso )
2. boot fedora. 

Actual results:
After the boot goes past GRUB screen, this message comes up. 

Expected results:
n/a

Additional info:
I have tried it on another machine (Thinkpad T450) and this issue occurs.
Comment 1 Josh Boyer 2016-06-26 08:19:47 EDT
This looks to be from commit 0f8ede1b8c4cb845c53072d7e49d71ca24a61ced upstream.

Since we build with CONFIG_HIBERNATION, it does the weird WARN thing now.  We'll look into this but I'm not sure there's going to be a great resolution.
Comment 2 Josh Boyer 2016-06-26 08:25:05 EDT
Actually, this looks to have been fixed by commit 65fe935dd2387a4faf15314c73f5e6d31ef0217e in the tip tree.  That hasn't quite hit Linus' tree yet, but I suspect it will sometime next week.
Comment 3 deadrat 2016-07-05 04:40:40 EDT
(In reply to Josh Boyer from comment #2)
> Actually, this looks to have been fixed by commit
> 65fe935dd2387a4faf15314c73f5e6d31ef0217e in the tip tree.  That hasn't quite
> hit Linus' tree yet, but I suspect it will sometime next week.

Thanks for the update and thanks for looking into it!
Comment 4 Bill 2016-08-25 21:12:29 EDT
This has now showed up in Fedora 24 with 4.7.2-200.fc24.x86_64 update that came through updates testing today.
Comment 5 Christian Stadelmann 2016-08-28 07:52:19 EDT
(In reply to Bill from comment #4)
> This has now showed up in Fedora 24 with 4.7.2-200.fc24.x86_64 update that
> came through updates testing today.

Confirmed, same issue here with this exact same kernel version on F24.
Comment 6 RudraB 2016-08-31 08:43:08 EDT
I have not faced it with 4.7.2-200.fc24.x86_64 (installed from updates-testing), but with 4.7.2-201 (installed using koji download-build), this error came up.
Comment 7 Talip Durmuş 2016-09-03 10:02:38 EDT
I'm using Fedora 24 and after 4.7.2 kernel update this error came up
Comment 8 SteveCr48 2016-09-03 10:45:56 EDT
This isn't a bug or warning per se. The Fedora devs have chosen to build the kernel with CONFIG_HIBERNATION, as noted above. 

We can learn from the LKML, the kernel developers prioritized CONFIG_RANDOMIZE_BASE over CONFIG_HIBERNATION to improve security. The kernel team recommends DISABLING hibernation by default AND passing "nokaslr" on the kernel command line. 

The kernel patch produces the message reported: 

-#ifdef CONFIG_HIBERNATION
-	if (!cmdline_find_option_bool("kaslr")) {
-		debug_putstr("KASLR disabled by default...\n");
-		goto out;

If my understanding is correct, the Fedora devs may want to disable hibernation by default and give users the option of modifying the kernel command line. According to LKML, implementing kASLR will improve security
Comment 9 Josh Boyer 2016-09-03 11:14:04 EDT
(In reply to SteveCr48 from comment #8)
> This isn't a bug or warning per se. The Fedora devs have chosen to build the
> kernel with CONFIG_HIBERNATION, as noted above. 
> 
> We can learn from the LKML, the kernel developers prioritized
> CONFIG_RANDOMIZE_BASE over CONFIG_HIBERNATION to improve security. The
> kernel team recommends DISABLING hibernation by default AND passing
> "nokaslr" on the kernel command line. 
> 
> The kernel patch produces the message reported: 
> 
> -#ifdef CONFIG_HIBERNATION
> -	if (!cmdline_find_option_bool("kaslr")) {
> -		debug_putstr("KASLR disabled by default...\n");
> -		goto out;
> 
> If my understanding is correct, the Fedora devs may want to disable
> hibernation by default and give users the option of modifying the kernel
> command line. According to LKML, implementing kASLR will improve security

That's inaccurate.  As I said in comment #2, the issue is fixed.  It is now in Linus' tree but didn't make the 4.7.y kernel.  The options are to wait for 4.8.y or to backport the patch that fixes it.
Comment 10 Joseph McMurray 2016-09-03 14:17:34 EDT
(In reply to Bill from comment #4)
> This has now showed up in Fedora 24 with 4.7.2-200.fc24.x86_64 update that
> came through updates testing today.

Getting this issue with 4.7.2-201.fc24.x86_64

Also loading the previous kernel versions from grub gets me an error "Oops something went wrong"

Just installed some pending updates this morning which started this issue. Everything was working fine before then.
Comment 11 Joseph McMurray 2016-09-03 15:39:17 EDT
(In reply to Joseph McMurray from comment #10)
> (In reply to Bill from comment #4)
> > This has now showed up in Fedora 24 with 4.7.2-200.fc24.x86_64 update that
> > came through updates testing today.
> 
> Getting this issue with 4.7.2-201.fc24.x86_64
> 
> Also loading the previous kernel versions from grub gets me an error "Oops
> something went wrong"
> 
> Just installed some pending updates this morning which started this issue.
> Everything was working fine before then.

Disregard the later half of that comment. That is something separate.
Comment 12 Dolmio 2016-09-04 11:23:27 EDT
Confirmed with 4.7.2-201.fc24.x86_64 on two different laptops
Comment 13 Andreas Schöneck 2016-09-05 02:30:36 EDT
Some information for the F24 users on how this is going to be officially tackled would be nice. As far as I can see, there are at least a couple of options including:

* re-configuring the kernel command line -- is this then being done by updates to the respective packages?

* back-porting the changes from https://patchwork.kernel.org/patch/9199367/ to 4.7.* kernels and building new kernel packages

* leave the choice up to the users, potentially having all their kernels producing warnings at boot time -- should provide some kind of mini-how-to then

Any statements?
Comment 14 Dan Loomis 2016-09-05 03:29:01 EDT
Now in Fedora 23 as well.  4.7.2-101.fc23.x86_64 landed on September 04.
Comment 15 Jalal Ahmed 2016-09-05 12:03:43 EDT
This message "kaslr disabled: 'kaslr not on cmdline (hiberation selected)" has appeared after the laptop got a sudden switched of because the battery.
I thought it was because of this, I am using SSD.
I am using F24.
Waiting for a new kernel update.
Comment 16 Matthias31 2016-09-07 05:46:33 EDT
Same problem on a DELL Optiplex 790 but not on my Dell Optiplex 760, Asus notebook and HP Pavilion x360 II.
Comment 17 Matthias31 2016-09-07 05:51:32 EDT
For those not using hibernation, adding "nohibernate" to the kernel append line does make the KASLR disabled message go away.
Comment 18 Ali Zeynali 2016-09-07 09:07:30 EDT
yep! Same problem in Fedora 24(Kernel Version:  4.7.2_201)
Comment 19 Fedora Update System 2016-09-08 11:40:59 EDT
kernel-4.7.3-200.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f9d5f8f03f
Comment 20 Fedora Update System 2016-09-08 11:42:38 EDT
kernel-4.7.3-100.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-91fb402c7f
Comment 21 Christopher 2016-09-09 09:29:14 EDT
I confirm, the message is present on my F23 system after the update to 4.7.2-201.fc23.x86_64
Comment 22 Fedora Update System 2016-09-09 13:56:46 EDT
kernel-4.7.3-100.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-91fb402c7f
Comment 23 Mike Molina 2016-09-09 17:26:16 EDT
I confirm this situation in a virtual machine. My machine virtual
is virtualbox for windows (version 5.0.26 r108824 - 64 bit) running
Fedora 23 - 64 bit with kernel 4.7.2-101.fc23.x86_64. After of
message "kaslr disabled: 'kaslr' not on cmdline (hiberation selected)",
the system is frozen and does not allow start Session in my account.
Comment 24 rhbug 2016-09-11 05:03:19 EDT
(In reply to Matthias31 from comment #17)
> For those not using hibernation, adding "nohibernate" to the kernel append
> line does make the KASLR disabled message go away.

For me on 4.7.2-101.fc23.x86_64 adding "nohibernate" didn't, but adding "kaslr" did.
Comment 25 Fedora Update System 2016-09-12 11:27:13 EDT
kernel-4.7.3-200.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f9d5f8f03f
Comment 26 Bill 2016-09-12 20:46:39 EDT
Installed kernel 4.7.3-200.fc24 from updates testing and I can confirm that the problem is resolved for me,.
Comment 27 Fedora Update System 2016-09-13 18:22:23 EDT
kernel-4.7.3-200.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2016-09-13 21:19:01 EDT
kernel-4.7.3-100.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 29 Ernst 2016-09-13 22:25:55 EDT
A quick question.  What do ordinary folk do when this has wiped out their Fedora?

My screen flashes for a while trying to start Gnome display manager.

So again.... What do folk that can't access their system do to update so it works?
sent from my iPhone.
Comment 30 Christian Stadelmann 2016-09-14 02:27:08 EDT
(In reply to Ernst from comment #29)
> A quick question.  What do ordinary folk do when this has wiped out their
> Fedora?
> 
> My screen flashes for a while trying to start Gnome display manager.
> 
> So again.... What do folk that can't access their system do to update so it
> works?
> sent from my iPhone.

1. This issue surely didn't wipe out anyone's Fedora.
2. If your system doesn't boot, try to select an older kernel or a rescue kernel on boot.
3. go to a tty (Ctrl+Alt+F3 for example) and try to log in from there. Can you access the syslog (journalctl)? There should be some useful info there.
4. Put your question on ask.fedoraproject.org, the fedora forums or on https://lists.fedoraproject.org/archives/list/users@lists.fedoraproject.org/ . If you know what you're doing, file a bug here on this bugzilla instead.
Comment 31 Irwin 2016-09-15 14:41:07 EDT
I'm running Fedora 24 on VirtualBox. I updated my kernel to kernel-4.7.3-200.fc24.x86_64 but the the system still crashes before it can start Gnome. Adding kaslr, nokaslr, or nohibernate doesn't help. The last kernel that works is kernel-4.6.7-300.fc24.x86_64. I can't get a syslog because I can't switch to a TTY after the crash, and after rebooting with the working kernel, the boot syslog gets updated with the successful boot.
Comment 32 Laura Abbott 2016-09-15 15:50:46 EDT
This issue is not related to anything than a single print message. If you are having any other issue please open a separate bugzilla.
Comment 33 Irwin 2016-09-15 16:55:37 EDT
(In reply to Laura Abbott from comment #32)
> This issue is not related to anything than a single print message. If you
> are having any other issue please open a separate bugzilla.

You're right, sorry about that. I figured it might still be related to this issue based on Comment 29. For what it's worth, the issue I was is fixed by updating Virtual Box and the Guest Additions: http://unix.stackexchange.com/questions/309076/fedora-24-kernel-4-7-2-201-crash-on-boot-once-virtualbox-guest-additions-have

Note You need to log in before you can comment on or make changes to this bug.