Bug 13502 - openssl-0.9.5a-2 doesn't build on sparc
openssl-0.9.5a-2 doesn't build on sparc
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openssl (Show other bugs)
6.2
sparc Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-05 11:30 EDT by shuey
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-06 17:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shuey 2000-07-05 11:30:47 EDT
openssl-0.9.5a-2 will not build on sparc.  This is due to a problem in the
specfile; a patch to fix this follows.  It's being configured to use some
assembly routines that aren't there for non-x86 archs and -DL_ENDIAN is
given (should be -DB_ENDIAN).  I've applied this patch to the specfile and
it built correctly on a fresh RedHat 6.2 system.  Please update the SRPMS
on ftp.redhat.de; it'd be nice if the replacements were RPMv3 archives, not
RPMv4, since rh6.2 doesn't ship with support for RPMv4 archives.  Thanks.


--- openssl.spec.orig   Wed Jul  5 00:54:26 2000
+++ openssl.spec        Wed Jul  5 10:23:56 2000
@@ -1,7 +1,7 @@
 Summary: Secure Sockets Layer communications libs & utils
 Name: openssl
 Version: 0.9.5a
-Release: 2
+Release: 3
 Source: http://www.openssl.org/source/%{name}-%{version}.tar.gz
 Source1: Makefile.certificate
 Copyright: BSDish
@@ -41,20 +41,25 @@
 %ifarch mips
 perl Configure linux-mips
 %else
-%ifarch alpha
+%ifarch alpha sparc sparc64
 sh config no-asm
 %else
 sh config
 %endif
 %endif
 perl util/perlpath.pl %{_bindir}
-%ifarch i386 i486 i586 i686 i786 i886 i968
+%ifarch i386 i486 i586 i686 i786 i886 i986 k6 k7
 make all CFLAG="$RPM_OPT_FLAGS -DL_ENDIAN -DTERMIO -Wall -Wuninitialized
-DSHA1_ASM -DMD5_ASM -DRMD160_ASM"
 make linux-shared CFLAG="$RPM_OPT_FLAGS -DL_ENDIAN -DTERMIO -Wall
-Wuninitialized -DSHA1_ASM -DMD5_ASM -DRMD160_ASM"
 %else
+%ifarch sparc sparc64
+make all CFLAG="$RPM_OPT_FLAGS -DB_ENDIAN -DTERMIO -Wall -Wuninitialized
-DNO_ASM"
+make linux-shared CFLAG="$RPM_OPT_FLAGS -DB_ENDIAN -DTERMIO -Wall
-Wuninitialized -DNO_ASM"
+%else
 make all CFLAG="$RPM_OPT_FLAGS -DL_ENDIAN -DTERMIO -Wall -Wuninitialized
-DNO_ASM"
 make linux-shared CFLAG="$RPM_OPT_FLAGS -DL_ENDIAN -DTERMIO -Wall
-Wuninitialized -DNO_ASM"
 %endif
+%endif
 make DIRS=apps
 LD_PRELOAD="`pwd`/libcrypto.so `pwd`/libssl.so" make rehash test
 
@@ -110,6 +115,9 @@
 %postun -p /sbin/ldconfig
 
 %changelog
+* Wed Jul  5 2000 Mike Shuey <shuey@ecn.purdue.edu>
+- Fix build on sparc
+
 * Tue Jun 20 2000 Than Ngo <than@redhat.de>
 - use RPM macros
Comment 1 Nalin Dahyabhai 2000-07-06 17:29:05 EDT
*** Bug 13515 has been marked as a duplicate of this bug. ***
Comment 2 Nalin Dahyabhai 2000-10-01 21:25:39 EDT
Guinness builds of openssl also built on Sparc; they'll show up in the next Raw
Hide refresh.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.