Bug 1350262 - Xorg hangs randomly with nouveau driver mostly on libreoffice splash page
Summary: Xorg hangs randomly with nouveau driver mostly on libreoffice splash page
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-26 20:42 UTC by Marek Greško
Modified: 2017-12-12 10:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:36:29 UTC
Type: Bug


Attachments (Terms of Use)
Log from the time freeze occured (38.89 KB, application/octet-stream)
2016-06-26 20:42 UTC, Marek Greško
no flags Details
Kernel trace (4.55 KB, text/plain)
2016-11-12 11:56 UTC, Marek Greško
no flags Details

Description Marek Greško 2016-06-26 20:42:02 UTC
Created attachment 1172653 [details]
Log from the time freeze occured

Description of problem:
Xorg hangs randomly with nouveau driver. It happens mostly when runnig libreoffice while displaying splash page of libreoffice, but not limited to. It happens probably every two days. Sometime more often. The result is that all windows are frozen. Mouse cursor moves. Unable to switch to console. Alt+Sysrq+REISUB works. Ssh connection to the machine works.

Version-Release number of selected component (if applicable):
1.0.12-4.fc24.x86_64

How reproducible:
Occasionally.

Steps to Reproduce:
1. Use computer.
2. Run libreoffice.
3. Probable freeze.

Actual results:
Machine freezes.

Expected results:
Machine does not freeze.

Additional info:

Comment 1 Marek Greško 2016-06-26 20:45:25 UTC
Just forgot to specify, that machine does not freeze with nvidia drivers.

Comment 2 Sammy 2016-07-01 13:26:43 UTC
To add another data point the hang also happens with KDE plasma 5 kickers
"Application Dashboard", which is a full screen dashbaord over the other 
windows for the application menus (similar in character to a splash). The
hang does not happen every time but when it does only a hard reboot is
possible.

Comment 3 Marek Greško 2016-07-13 18:20:10 UTC
So it seems the fullscreen objects trigger the crash? The splash screens, full screen video?

Comment 4 Marek Greško 2016-11-12 02:44:50 UTC
Present also in Fedora 25.

Comment 5 Marek Greško 2016-11-12 11:56:16 UTC
Created attachment 1219991 [details]
Kernel trace

Comment 6 Marek Greško 2016-11-12 11:58:24 UTC
After upgrading to Fedora 25 I am no longer able to use nvidia340 drivers, so I have to try some tweeks to avoid this bug, since computer is now nearly unusable.

I attached a kernel trace which may be related.

I tried following to avoid problems:

1. Upgraded Fedora 24 to Fedora 25.

2. Disabled wayland for gdm.

3. Created script with export QSG_RENDER_LOOP=basic in profile.d.

4. Logged in as a first user to the kde session.

5. Pressed Ctrl+Alt+F1 to get gdm login screen.

6. Logged in as a second user to the kde session.

7. Both kde sessions were stuck, but as opposed to previous behaviour I was able to Ctrl+Alt+Backspace both sessions (maybe because of previous steps I did not use before).

8. After turning down second kde session got previously attached kernel trace.

Does it seem related?

Comment 7 Marek Greško 2016-12-02 10:14:41 UTC
Is there any workaround to get stable 2D desktop without crashing?

Comment 8 Marek Greško 2017-01-05 18:20:44 UTC
I tried replace my GT210 with GT730. Same crashes, but different logs.

Moved to Radeon. Now rock solid.

I no longer have the nvidia hardware, so I will not be able to confirm the bug is fixed.

Comment 9 Fedora End Of Life 2017-11-16 19:51:29 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 10 Fedora End Of Life 2017-12-12 10:36:29 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.