Bug 135031 - DATA LOSS installing into existing partition (w/ assertion fail)
DATA LOSS installing into existing partition (w/ assertion fail)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-08 02:55 EDT by don
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-10 22:13:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description don 2004-10-08 02:55:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Not sure if this is one problem or two, but the RUMORS ABOUT FC3T2
PARTITIONING PROBLEMS & DATA LOSS ARE TRUE!

While trying to install into this preexisting extended partition:

/dev/hda4            1201        3648    19663560    5  Extended

/dev/hda5            3626        3648      184747+  82  Linux swap
/dev/hda6            1201        1290      722893+   6  FAT16
/dev/hda7            1291        1380      722893+   6  FAT16
/dev/hda8            2081        3625    12410212+  83  Linux
/dev/hda9            1381        2080     5622687   83  Linux

(yes they are out of order on purpose)

I got this this failed assertion:

Assertion metadata_length >= bios_geom.sectors at disk_dos.c:1739 in
function _add_logical_part_metadata() failed

I was attempting to format as ext3 and install into hda9. 

The install went ok but the the system failed to boot because the
majority of the extended partition table was wiped out. Namely, there
were about 14 identical copies of hda5 in place of hda6+.

I did not have this problem with fc3t1 but who knows...

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. not sure if partition table will do it alone.
2.
3.
    

Additional info:
Comment 1 Jeremy Katz 2004-10-10 22:13:26 EDT
This should be fixed with the newer parted in test3.

Note You need to log in before you can comment on or make changes to this bug.