Bug 135033 - 2.6.8-1.598 hangs on reboot
2.6.8-1.598 hangs on reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-10-08 03:09 EDT by Chris Ricker
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 09:35:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2004-10-08 03:09:52 EDT
Dell 2850

2.6.8-1.598 flushes the cache on the PERC card and then hangs when
rebooting

2.6.8-1.541 didn't have this problem
Comment 1 Chris Ricker 2004-10-08 03:15:12 EDT
lspci output is:

00:00.0 Host bridge: Intel Corp. Server Memory Controller Hub (rev 09)
00:02.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
A0 (rev 09)
00:04.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
B0 (rev 09)
00:05.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
B1 (rev 09)
00:06.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
C0 (rev 09)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#3 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
01:00.0 PCI bridge: Intel Corp. 80332 [Dobson] I/O processor (rev 06)
01:00.2 PCI bridge: Intel Corp. 80332 [Dobson] I/O processor (rev 06)
02:0e.0 RAID bus controller: Dell Computer Corporation: Unknown device
0013 (rev 06)
05:00.0 PCI bridge: Intel Corp. PCI Bridge Hub A (rev 09)
05:00.2 PCI bridge: Intel Corp. PCI Bridge Hub B (rev 09)
06:07.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet
Controller (rev 05)
07:08.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet
Controller (rev 05)
08:00.0 PCI bridge: Intel Corp. PCI Bridge Hub A (rev 09)
08:00.2 PCI bridge: Intel Corp. PCI Bridge Hub B (rev 09)
0b:0d.0 VGA compatible controller: ATI Technologies Inc Radeon RV100
QY [Radeon 7000/VE]
Comment 2 victor lorenz 2004-10-08 10:21:39 EDT
AMD Athlon

Kernel 598 also hangs:

insmod: error inserting '/lib/ext3.ko': -1 unknown symbol
ERROR: /bin/insmod exited abnormally
etc.

590 had same problem
Comment 3 victor lorenz 2004-10-08 13:32:14 EDT
Same problem with 1.603
Comment 4 Bill Nottingham 2004-10-15 11:49:21 EDT
Victor: your error is unrelated to Chris's error - could you file a
new bug?
Comment 5 Tom Coughlan 2004-10-16 16:22:09 EDT
Chris,

Based on the PCI ID, the PERC card you have uses the megaraid_mbox
driver. Right?

The diff between 541 and 598 shows some minor changes in the
megaraid_mbox driver, mostly cosmetic. It does not look like the
likely cause.

On a successful boot, what is the next message after the one about
flushing the PERC cache?

Have you tried a more recent kernel?

Tom



Comment 6 Tom Coughlan 2004-10-18 10:38:31 EDT
Chris,

We reproduced the problem on a similar system, a Dell 1850. The
problem on that system is fixed in the 624 kernel. Please try the 624
kernel, available on rawhide.

Tom
Comment 7 Dave Jones 2004-11-27 15:25:29 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 8 victor lorenz 2004-11-27 15:52:53 EST
No longer a problem with 2.6.9 (ok since 2.6.8-1.624)

Note You need to log in before you can comment on or make changes to this bug.