Bug 135039 - cannot quit from canna LE candidate window by with Esc
cannot quit from canna LE candidate window by with Esc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Canna (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: FC3Target IIIMF FC4Target
  Show dependency treegraph
 
Reported: 2004-10-08 03:37 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: im-sdk-12.1-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 06:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-10-08 03:37:03 EDT
Description of problem:
When in any candidate selection menu, ESC should escape and cancel
that menu and/or character conversion.
Comment 1 Akira TAGOH 2004-10-08 03:57:11 EDT
it highly depends on the implementation of LEs. since all of key
events is processed on each LEs and to sync the state after escaping.
Comment 2 Leon Ho 2004-10-11 21:35:16 EDT
As taogh-san said. Which specific LE are you experiencing this on?
Need to change it to specific componment if available.
Comment 3 Warren Togami 2004-10-11 22:03:45 EDT
This wouldn't be a good idea for all LE's?

This should really be done for all LE's, and also that pop-up menu
that is similar to a candidate selection in navigation, except it
makes you choose an LE.  That is not specific to any LE, so cannot be
assigned to a specific LE.
Comment 4 Leon Ho 2004-10-11 22:56:36 EDT
If you test iiimf-xcin, you can use 'escape' to close the candidate
section. It is the one of the must function for closing candidate
window, but it has to be handled (or more make sense) because:
1. LE is handling lookup candidates data
2. LE has to pass iml_make_lookup_done_inst() to finish the candidate
window
3. LE has to handle to clear any preedit buffer they have in their
data structure

So it is implemented within LE.

However from comment #3, look like you are talking about the LE
switching feature menu (i.e. ctrl-shift-space), but not candidate
window. Then yes, it is within im-sdk lib.
Comment 5 Leon Ho 2004-10-11 22:58:18 EDT
Steps to reproduce:
1. LANG=ja_JP.UTF-8 GTK_IM_MODULE=iiim gedit
2. press ctrl-shift-space
3. press escape

Actual results:
cannot quit the selection window

Expected results:
escape out from selection window
Comment 6 Akira TAGOH 2004-10-21 09:06:24 EDT
as the summary has been changed, I reassign this to Canna. Canna has a
way to escape from something. and Escape key hasn't been assigned such
behavior right now.
Comment 7 Warren Togami 2004-11-05 06:12:27 EST
This has been checked in and built for RHEL4, and we should probably
also issue a FC2 & FC3 update soon.  I need to discuss this with the
eng-i18n team.  Hopefully other improvements to the Canna package can
be made too to make it a more worthwhile upgrade.
Comment 8 Lawrence Lim 2004-11-09 04:15:41 EST
Tagoh,
At the moment, the ESC only quit the canna LE candidate window in i386
machine. But on x86_64 machine, it does not.

One more thing, is it possible to implement the ESC key to the Canna
configuration aux? The menu that pops up when the Home key is press?
Comment 9 Lawrence Lim 2004-11-09 05:13:44 EST
After an upgrade of Canna server to Canna-3.7p3-7 everything is
working pefectly now. 

Just need to know if it is possible to implement the ESC key to the
Canna configuration aux? The menu that pops up when the Home key is
press? Or should I file another bug for the aux?
Comment 10 Lawrence Lim 2004-11-09 06:00:50 EST
After a quick discussion with tagoh, to escape from aux, the ESC key
should be processed by the IIIMF server. Will create a new bug for
this issue.


Thanks.

Note You need to log in before you can comment on or make changes to this bug.