Bug 135046 - ruby-devel doesn't require ruby
ruby-devel doesn't require ruby
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-08 05:01 EDT by Frank Schmitt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 06:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Schmitt 2004-10-08 05:01:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
ruby-devel only requires ruby-libs and neither ruby-devel nor
ruby-libs require ruby itself, but without ruby, ruby-libs and
ruby-devel are useless.

Version-Release number of selected component (if applicable):
ruby-devel-1.8.1-2.1

How reproducible:
Always

Steps to Reproduce:
1. Install ruby-devel and ruby-libs and see that they don't require
ruby itself.

Additional info:
Comment 1 Akira TAGOH 2004-10-08 06:05:31 EDT
No, as the package description says, ruby-devel is to developt the
extension library. and for that, ruby interpreter itself (which ruby
package contains) isn't required for that. and though eruby requires
ruby-libs, ruby interpreter itself isn't also required to get working
for eruby. that's why ruby-devel and ruby-libs didn't requires ruby.
so this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.