Bug 135048 - rpms are not uninstalled in "dependency order"
Summary: rpms are not uninstalled in "dependency order"
Status: CLOSED DUPLICATE of bug 158577
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-08 09:49 UTC by Rolf Wilteus
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 22:18:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example spec file for dummy base package (399 bytes, text/plain)
2004-10-08 09:50 UTC, Rolf Wilteus
no flags Details
Example spec file for dummy application package (742 bytes, text/plain)
2004-10-08 09:50 UTC, Rolf Wilteus
no flags Details

Description Rolf Wilteus 2004-10-08 09:49:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When several packages are uninstalled using a single rpm invocation
they are not uninstalled in proper dependency order.

Example: I have two packages, base and application.
Application requires base.

When installing both with "rpm -U base.rpm application.rpm" then
base is installed first (even if I use "rpm -U application.rpm
base.rpm"). Just as it should be.

When uninstalling them "rpm -e base application" and "rpm -e
application base" gives different results. Then the packages seems to
be uninstalled in reverse command line argument order. That breaks the
dependency and my application requires base to be available in the
preun section.

Version-Release number of selected component (if applicable):
rpm-4.2.1

How reproducible:
Always

Steps to Reproduce:
1. Build attached packages
2. Install them
3. Try both variants of "rpm -e" as mentioned above
    

Actual Results:  Different uninstall order

Expected Results:  The same order. application should always be
uninstalled before base since it has a "requires base" dependency.

Additional info:

Comment 1 Rolf Wilteus 2004-10-08 09:50:01 UTC
Created attachment 104926 [details]
Example spec file for dummy base package

Comment 2 Rolf Wilteus 2004-10-08 09:50:52 UTC
Created attachment 104927 [details]
Example spec file for dummy application package

Comment 3 Barry K. Nathan 2004-10-25 09:25:42 UTC
I think this is a duplicate of bug 129875

Comment 4 Paul Nasrat 2005-11-28 22:18:01 UTC
Collapsing into common rpm sorted erasure bug


*** This bug has been marked as a duplicate of 158577 ***


Note You need to log in before you can comment on or make changes to this bug.