Bug 1350535 - sssd needs access to /etc/sssd/conf.d
Summary: sssd needs access to /etc/sssd/conf.d
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1357524 (view as bug list)
Depends On:
Blocks: 1376681
TreeView+ depends on / blocked
 
Reported: 2016-06-27 17:01 UTC by Jakub Hrozek
Modified: 2016-11-04 02:32 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-3.13.1-83.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1376681 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:32:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1373265 medium CLOSED sssd need write access to /etc/sssd/ 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:2283 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Internal Links: 1373265

Description Jakub Hrozek 2016-06-27 17:01:23 UTC
Description of problem:
We added an include directory to sssd, but without selinux-policy changes, we see avc denials

type=AVC msg=audit(06/23/2016 10:44:57.486:910) : avc:  denied  { read } for
pid=27671 comm=sssd name=conf.d dev="dm-1" ino=1871243
scontext=system_u:system_r:sssd_t:s0 tcontext=system_u:object_r:sssd_conf_t:s0
tclass=dir permissive=0

We need to allow sssd to read the contents of /etc/sssd/conf.d

Comment 2 Lukas Slebodnik 2016-06-27 17:41:37 UTC
and AVCs in permissive mode
type=AVC msg=audit(06/27/2016 19:40:32.511:3430) : avc:  denied  { read } for  pid=16491 comm=sssd name=conf.d dev="dm-1" ino=1871243 scontext=system_u:system_r:sssd_t:s0 tcontext=system_u:object_r:sssd_conf_t:s0 tclass=dir permissive=1 
----
type=AVC msg=audit(06/27/2016 19:40:32.511:3431) : avc:  denied  { getattr } for  pid=16491 comm=sssd name=/ dev="dm-1" ino=256 scontext=system_u:system_r:sssd_t:s0 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem permissive=1

Comment 7 Lukas Vrabec 2016-07-18 12:41:08 UTC
*** Bug 1357524 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2016-11-04 02:32:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html


Note You need to log in before you can comment on or make changes to this bug.