Bug 135056 - After bugfix update of cyrus-sasl, openldap and postfix segfault
After bugfix update of cyrus-sasl, openldap and postfix segfault
Status: CLOSED DUPLICATE of bug 134979
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cyrus-sasl (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-08 07:17 EDT by Graham Leggett
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2004-10-08 07:17:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040925

Description of problem:
After applying the latest cyrus-sasl update via up2date, all access to
LDAP breaks like so:

[root@gatekeeper rpms]# ldapsearch
Segmentation fault
[root@gatekeeper rpms]# strace ldapsearch
execve("/usr/bin/ldapsearch", ["ldapsearch"], [/* 36 vars */]) = 0
[snip]
getrlimit(RLIMIT_NOFILE, {rlim_cur=1024, rlim_max=1024}) = 0
open("/etc/openldap/ldap.conf", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=392, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb75f8000
read(3, "# $OpenLDAP: pkg/ldap/libraries/"..., 4096) = 392
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0xb75f8000, 4096)                = 0
getuid32()                              = 0
geteuid32()                             = 0
getgid32()                              = 0
getegid32()                             = 0
open("/root/ldaprc", O_RDONLY)          = -1 ENOENT (No such file or
directory)
open("/root/.ldaprc", O_RDONLY)         = -1 ENOENT (No such file or
directory)
getuid32()                              = 0
geteuid32()                             = 0
getgid32()                              = 0
getegid32()                             = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Postfix also breaks, complaining of signal 11's.


Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.15-9

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Suzanne Hillman 2004-10-12 15:33:46 EDT

*** This bug has been marked as a duplicate of 134979 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.