Bug 135063 - Install Kernel fails to detect SATA hard disk on i915 ICH
Install Kernel fails to detect SATA hard disk on i915 ICH
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-10-08 08:59 EDT by Rainer Koenig
Modified: 2013-07-02 22:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 04:18:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of lspci (1.67 KB, text/plain)
2004-10-21 10:04 EDT, Rainer Koenig
no flags Details

  None (edit)
Description Rainer Koenig 2004-10-08 08:59:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040917 Firefox/0.9.3

Description of problem:
Trying to install. Booting 1st CD starts installer, but the kernel
used on this CD fails to detect any hard drive connected to the SATA
port on this machine. So no installation is possible.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD
2. See the error message that no hard drives are detected
3.
    

Actual Results:  Installation fails.

Expected Results:  Kernel detects hard drive as either ide-device or
(like the Taroon kernel) as a "SCSI" device.

Additional info:
Comment 1 Jeff Garzik 2004-10-20 18:36:24 EDT
I need more information in order to diagnose this.

Can you provide more details about your hardware?

Is the SATA port on a card, or on the motherboard?

Is the motherboard ICH5, ICH5-R, ICH5-M, ICH6, ICH6-R, ICH6-M, other?

Is 'lspci' output available?

Is SATA enabled in your BIOS, and 'enhanced mode' selected?
Comment 2 brandon 2004-10-20 23:08:15 EDT
I am having the exact same problem on an AMD 64 with both RHEL 3, as
well as beta 4.  Fedora core also exhibits the same behavior.  
Specs:
AMD64 3200
ATI Radeon 9600 pro
Gigabyte GA-K8NS Pro motherboard
80 gig WD hard drive (SATA)
Hard drive specs can be found here:
http://www.giga-byte.com/MotherBoard/Products/Products_Spec_GA-K8NS%20Pro.htm

What is interesting about this board is that it has two SATA
controllers.  One is a Silicon Image Sil3512, the other is Nvidia
Nforce3.  After much diging I finally found somewhat of an explanation
on Nvidia's web site (under linux drivers for AMD64) and the sollution
basically involved installing on a PATA drive, pathing and then
rebuilding the kernel, and then transfering to the SATA drive.  Way
too much work for me right now.  So I unplugged my SATA drive from the
Nvidia plug and used the Sil3512 chip,  which to my exitment worked. 
I apologize for not providing a more detailed description of the bug,
however it was described verry nicely to begin with, and Nvidia has
posted a good explanation on their web site(under the FAQS of the 64
bit drivers section).  The sollution for me was to stop using the
Nvidia SATA controller.  Hope this helps.  
Comment 3 Rainer Koenig 2004-10-21 10:04:27 EDT
Created attachment 105586 [details]
Output of lspci

lspci output from Fujitsu Siemens Mainboard D1858
Comment 4 Rainer Koenig 2004-10-21 10:08:34 EDT
Ok, meanwhile I did a BIOS upgrade and now I can install the thing
when I set SATA to "compatible" mode in the BIOS. If I use "native"
Mode then its not working again, but at least I can install using the
compatible mode (even if then I'm limited to a lower number of SATA
drives). So from my point of view the issue is less critical now.

The Hardware is a Fujitsu-Siemens D1858 Mainboard in a Celsius M430
Workstation. I attach a file with the lspci.output to this note. 

But after doing the install I still have problems with the system.
I'll go and investigate this deeper (BTW: Why doesn't
"console=/dev/ttyS0,9600n8" work anymore to capture the messages on a
PC connected by null modem cable?) because I guess there could be a
dependency on the graphics card (actual ATI PCI-Expres) as well since
after the installation the X-Server seems to hang on the first boot
and after rebooting I get kernel panics.

As for the initial issue "kernel is not detecting SATA drives" this
look much better now, even if "native mode" would be nice as well. I
reduce "severity" to "low" as a result of my latest findings.
Comment 6 Rainer Koenig 2008-03-05 04:18:54 EST
I close this bug as "WorksForMe". The issue might be that we had firmware
problems on WD drives related to NCQ. Anyway, this is not a problem any longer.

Note You need to log in before you can comment on or make changes to this bug.