Bug 1350695 - execution of copy-schema script fails
Summary: execution of copy-schema script fails
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-28 07:16 UTC by Kaleem
Modified: 2016-11-04 05:55 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:55:31 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Kaleem 2016-06-28 07:16:47 UTC
Description of problem:

While execution our migration test suite where we create 7.3 replica from 6.8 master, we need to copy copy-schema-to-ca.py from 7.3 vm on 6.8 Master and run it there . but i do see following error

[root@dhcp207-6 ~]# python copy-schema-to-ca.py 
Traceback (most recent call last):
  File "copy-schema-to-ca.py", line 24, in <module>
    from ipaplatform.constants import constants
ImportError: No module named ipaplatform.constants
[root@dhcp207-6 ~]#

Version-Release number of selected component (if applicable):
[root@dhcp207-129 ~]# rpm -q ipa-server
ipa-server-4.4.0-0.el7.2.alpha1.x86_64
[root@dhcp207-129 ~]# 

How reproducible:
Always

Steps to Reproduce:
1. Copy copy-schema-to-ca.py from RHEL-7.3 vm to RHEL-6.8 vm 
2. On RHEL-6.8 vm , run copy-schema-to-ca.py
3.

Actual results:
Execution of script fails

Expected results:
Execution of script should have been successful .

Additional info:

Comment 1 Petr Vobornik 2016-06-28 07:31:18 UTC
Caused by: https://git.fedorahosted.org/cgit/freeipa.git/commit/?id=49be6c8d3cc20902dbe8e92a74e31aed2fd21d9f

copy-schema-to-ca.py part of the patch should be reverted.

commits:
e4075b1fe26a608cd1f3778ee1f655a5f5700c65 Remove unused imports
27dabb45282911e375336f75934af9dd6cc5d963 Modernize 'except' clauses
b8c46f2a32d0d8c2dc6ef0867f85f63cf076a004 Modernize number literals

Should be also investigated if they doesn't cause issues on RHEL 6.

Comment 2 Petr Vobornik 2016-06-28 07:33:51 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6003

Comment 5 Martin Bašti 2016-06-30 12:29:22 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/f3858be6e353fadf0b1da1c31b908264ddd636c5

Comment 7 Kaleem 2016-07-05 04:09:15 UTC
Verified.

IPA Server version:
===================
[root@dhcp207-47 ~]# rpm -q ipa-server
ipa-server-4.4.0-1.el7.x86_64
[root@dhcp207-47 ~]# 

Snip from console output:
=========================
[root@dhcp207-46 ~]# python copy-schema-to-ca.py
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/60kerberos.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/60samba.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/60ipaconfig.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/60basev2.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/60basev3.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/60ipadns.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/61kerberos-ipav3.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/65ipasudo.ldif
ipa         : INFO     Installed /etc/dirsrv/slapd-PKI-IPA//schema/05rfc2247.ldif
ipa         : INFO     Restarting CA DS
ipa         : INFO     Schema updated successfully
[root@dhcp207-46 ~]# ipactl restart
Restarting Directory

Comment 9 errata-xmlrpc 2016-11-04 05:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.