Bug 1350775 - xfce-polkit should not start on cinnamon desktop
Summary: xfce-polkit should not start on cinnamon desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce-polkit
Version: 24
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-28 11:18 UTC by Edgar Hoch
Modified: 2016-07-24 21:49 UTC (History)
2 users (show)

Fixed In Version: xfce-polkit-0.2-8.fc24 xfce-polkit-0.2-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 15:02:20 UTC
Type: Bug


Attachments (Terms of Use)
Error message window of xfce-polkit (16.67 KB, image/png)
2016-06-28 11:18 UTC, Edgar Hoch
no flags Details

Description Edgar Hoch 2016-06-28 11:18:17 UTC
Created attachment 1173368 [details]
Error message window of xfce-polkit

Description of problem:
When using cinnamon desktop, /usr/libexec/xfce-polkit is started on behave of file /etc/xdg/autostart/xfce-polkit.desktop . It contains an entry

NotShowIn=GNOME;KDE;

This doesn't match cinnamon, so it is started.

But cinnamon starts polkit-gnome-authentication-agent-1, as seen in the journal:

Jun 28 09:06:23 myhost.example.com polkitd[1434]: Registered Authentication Agent for unix-session:2 (system bus name :1.79 [/usr/libexec/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)

When xfce-polkit is started, it fails with the following message in journal:

Jun 28 09:06:25 myhost.example.com /usr/libexec/gdm-x-session[4752]: ** (xfce-polkit:5314): WARNING **: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent


Solution:

I think the problem is, that the NowShowIn entry in the autostart file does not match all existing desktops, because there exists more desktops than GNOME and KDE. It should be changed to

OnlyShowIn=XFCE;


Version-Release number of selected component (if applicable):
xfce-polkit-0.2-6.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install (at least) the desktops groups for cinnnamon and xfce.
2. Log in choosing desktop cinnamon

Actual results:
Error message on desktop and journal

Expected results:
No error

Comment 1 Raphael Groner 2016-06-28 11:55:57 UTC
Thanks for your report. You're right, I'll fix that.

Comment 2 Fedora Update System 2016-07-07 16:46:34 UTC
xfce-polkit-0.2-8.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-fe6d61623c

Comment 3 Fedora Update System 2016-07-07 16:46:41 UTC
xfce-polkit-0.2-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-40a67933c7

Comment 4 Fedora Update System 2016-07-10 03:18:05 UTC
xfce-polkit-0.2-8.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-fe6d61623c

Comment 5 Fedora Update System 2016-07-10 15:58:43 UTC
xfce-polkit-0.2-8.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-40a67933c7

Comment 6 Fedora Update System 2016-07-12 15:02:17 UTC
xfce-polkit-0.2-8.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-07-24 21:49:19 UTC
xfce-polkit-0.2-8.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.