Bug 135084 - vmware's /dev nodes dissappear
vmware's /dev nodes dissappear
Status: CLOSED DUPLICATE of bug 134641
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-08 11:12 EDT by Joseph Harnish
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Harnish 2004-10-08 11:12:31 EDT
Description of problem:
I am running VMWare workstation on a FC3T2 host.  when I run
vmware-config.pl it creates a handful of nodes in /dev for use by the
virtual machines.  When I reboot these dissappear and I need to rerun
vmware-config.pl

Version-Release number of selected component (if applicable):


How reproducible:
every reboot

Steps to Reproduce:
1.  Install VMWare
2.  run vmware-config.pl
3.  run vmware (works fine)
4.  reboot
5.  run vmware (missing nodes in /dev)

  
Actual results:
missing nodes in /dev

Expected results:
vmware should start right up

Additional info:
Comment 1 Joseph Harnish 2004-10-08 11:14:30 EDT
This could probably be fixed by changing the way VMWare works but it
might be nice if udev watches the /dev directory for new nodes being
added and adds them to a list of nodes that need to be generated on
reboot.

Comment 2 Warren Togami 2004-10-08 22:34:06 EDT

*** This bug has been marked as a duplicate of 134641 ***
Comment 3 Harald Hoyer 2004-10-11 04:21:55 EDT
the vmware kernel modules should provide a "dev" entry in the sysfs ...
Workaround:
manually copy the devices to /etc/udev/devices and they will be copied
on system start to /dev
see:
http://people.redhat.com/~harald/udev.html
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.