Bug 135092 - firstboot nag functionality doesn't work correctly
Summary: firstboot nag functionality doesn't work correctly
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: firstboot   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Max Spevack
URL:
Whiteboard:
Keywords:
: 125303 125536 132532 (view as bug list)
Depends On: 132532 132782
Blocks: 131623
TreeView+ depends on / blocked
 
Reported: 2004-10-08 16:08 UTC by Max Spevack
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 20:48:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:582 normal SHIPPED_LIVE Updated rhn-applet package 2004-12-21 05:00:00 UTC

Description Max Spevack 2004-10-08 16:08:49 UTC
Description of problem:
Behavior of nag functionality in firstboot is a bit choppy.

Nags should occur when:
- you do not provide a subscription number
- there is no base channel for the system

Adrian, am I missing any cases?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Adrian Likins 2004-10-08 19:52:37 UTC
rhn-applet-2.1.13

Comment 2 Max Spevack 2004-10-12 16:03:01 UTC
1.  If you set the nag interval to a low number, the main nag box will
continue to pop up even if you have proceeded to the smaller dialog
(ie: chosen the "do not activate" radio on the large screen.

Comment 3 Max Spevack 2004-10-12 19:56:53 UTC
In terms of the "nag when there is no base channel", the test plan is:

1.  create a  new account
2.  register the box in firstboot, choosing "use my existing entitlement"
3.  The box will appear with the demo entitlement and no base channel.

However, currently, when this happens, the rhn_register_remind file in
/etc/sysconfig/rhn isn't being created, and so no nagging occurs.

Comment 4 Max Spevack 2004-10-14 21:22:13 UTC
*** Bug 132532 has been marked as a duplicate of this bug. ***

Comment 5 Max Spevack 2004-10-14 21:30:51 UTC
Naggig is finally fixed, but I am leaving this bug in ON_DEV for a
reason mentioned at the end of this comment.

There are three cases for nagging:

1.  User chooses to avoid all RHN registration during firstboot.
2.  User has no networking configured.
3.  User enters no registration number, and therefore the system has
no base channel.

***Note that case 3 will only work on the code currently in dev***

Comment 6 Max Spevack 2004-11-12 21:16:59 UTC
*** Bug 125536 has been marked as a duplicate of this bug. ***

Comment 7 Max Spevack 2004-11-14 18:14:34 UTC
*** Bug 125303 has been marked as a duplicate of this bug. ***

Comment 8 Jay Turner 2004-11-26 10:55:20 UTC
Confirm nagging behavior with 2.1.18-4.

Comment 9 John Flanagan 2004-12-21 20:48:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-582.html



Note You need to log in before you can comment on or make changes to this bug.