Bug 13510 - OpenLDAP-1.2.10-4 not buildable by RPM 3.0.5
Summary: OpenLDAP-1.2.10-4 not buildable by RPM 3.0.5
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openldap   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-05 19:44 UTC by Bishop Clark
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-05 20:32:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bishop Clark 2000-07-05 19:44:13 UTC
As it says, an attempt to rpm --rebuild openldap-1.2.10-4.src.rpm will 
fail.  It may be better said that it simply stops running:

[root@atlas /tmp]#  rpm -ba /usr/src/redhat/SPECS/openldap.spec 
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.40233
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD

[...]

+ cp -pr doc/devel/README 
/var/tmp/openldap-root/usr/doc/openldap-devel-1.2.11
+ exit 0
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...
Requires: openldap
[root@atlas /tmp]# 

The particularly astute will notice that it didn't actually write anything. 
 My RPM 3.0.5 was just upgraded via a rebuild of rpm 305 using 304 and 
subsequent rpm -U and rpm --rebuilddb.  Nothing really drastic there.

All the src packages are fresh, straight from hammering rawhide.redhat.com 
(is there a mirror of that?) to pick them up.  The goal is to examine a 
reproducible segfault in LDAP, and so I'm hoping to get the new version so 
I can see if it still hates itself.

Thoughts?  Things I can run to test?  Should I try installing RPM4 and 
trying that tool?

 - bishop

Comment 1 Nalin Dahyabhai 2000-07-05 20:32:03 UTC
The [...] is the useful part of the build log.  The almost-latest
openldap-1.2.11-2.src.rpm went out in the last Raw Hide refresh;
it may be worth trying.  Since we're building everything with RPM 4
now, I'm not quite set up to test with 3.0.5....

Comment 2 Bishop Clark 2000-07-05 20:39:41 UTC
Sorry for omitting that part.  I was trying to show only where it was crashing, 
and not intentionally trying ot make life that much harder!  8-)

I will move to install RPM4 and see if the behaviour changes, then, with 
openldap-1.2.11-2.  Wish me luck.  More news to follow, but only really if the 
same behaviour repeats itself.  Thanks for the prompt reply.  Much appreciated!
 - bish.


Comment 3 kenneth_porter 2000-09-22 01:07:34 UTC
openldap-1.2.11-11 builds now with rpm-3.0.5-9.6x. The latter fixed a few RPM problems. See bug id 17782 for a new issue.


Note You need to log in before you can comment on or make changes to this bug.