Bug 135110 - Lomboz refuses to start Tomcat: many exceptions
Lomboz refuses to start Tomcat: many exceptions
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: eclipse (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-08 14:15 EDT by Graham Leggett
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:16:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2004-10-08 14:15:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040925

Description of problem:
After installing Lomboz in an attempt to develop a J2EE web
application, a number of exceptions are thrown when an attempt is made
to start up Tomcat:

java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.RangeCheck(ArrayList.java:507)
        at java.util.ArrayList.get(ArrayList.java:324)
        at
com.objectlearn.jdt.j2ee.ui.ModuleView.executeServer(Unknown Source)
        at com.objectlearn.jdt.j2ee.ui.J2EEView.launchServer(Unknown
Source)
        at
com.objectlearn.jdt.j2ee.ui.J2EEView$CompileAction.run(Unknown Source)

!ENTRY org.eclipse.ui 4 4 Oct 08, 2004 20:06:24.310
!MESSAGE Unhandled event loop exception
                                                                     
          
!ENTRY org.eclipse.ui 4 0 Oct 08, 2004 20:13:04.264
!MESSAGE java.lang.NullPointerException
!STACK 0
java.lang.NullPointerException
        at
com.objectlearn.jdt.j2ee.ui.ModuleView.executeServer(Unknown Source)
        at com.objectlearn.jdt.j2ee.ui.J2EEView.launchServer(Unknown
Source)
        at
com.objectlearn.jdt.j2ee.ui.J2EEView$CompileAction.run(Unknown Source)
        at org.eclipse.jface.action.Action.runWithEvent(Action.java:881)

Has Lomboz ever worked in this configuration at all?


Version-Release number of selected component (if applicable):
eclipse-lomboz-3.0-7

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Aaron Luchko 2004-10-08 15:31:43 EDT
I assume these errors are coming up on the command line not from the
console in eclipse?  It would also be useful to know what platform
this problem occured on along with the JVM used and what the operating
system is.  Also could you attach the log file?  The logfile is
located in workspace/.metadata/.log 

thank you
Comment 2 Graham Leggett 2004-10-08 17:07:39 EDT
The errors are showing up in the .log file.

What I did was opened up a project in eclipse that represents a WAR
file. In the Lombox view, I see my project with two modules beneath it
(I assume it's finding the WEB-INF directory, because there is one
module for the WEB-INF in the source, and a second for the WEB-INF in
the target directory). I select the target module (has the same name
as my project). I then click the launch button (the two cog wheels
icon). The log then contains this:

!SESSION Oct 08, 2004 23:00:04.384
---------------------------------------------eclipse.buildId=200406251208
java.version=1.4.2_02
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_ZA
                                                                     
          
!ENTRY com.objectlearn.jdt.j2ee 1 0 Oct 08, 2004 23:00:04.385
!MESSAGE Creating server definition
manager[/usr/share/eclipse/plugins/com.objectlearn.jdt.j2ee_3.0.0/]
                                                                     
          
!ENTRY org.eclipse.ui 4 4 Oct 08, 2004 23:04:11.543
!MESSAGE Unhandled event loop exception
                                                                     
          
!ENTRY org.eclipse.ui 4 0 Oct 08, 2004 23:04:11.544
!MESSAGE Index: 0, Size: 0
!STACK 0
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.RangeCheck(ArrayList.java:507)
        at java.util.ArrayList.get(ArrayList.java:324)
        at
com.objectlearn.jdt.j2ee.ui.ModuleView.executeServer(Unknown Source)
        at com.objectlearn.jdt.j2ee.ui.J2EEView.launchServer(Unknown
Source)
        at
com.objectlearn.jdt.j2ee.ui.J2EEView$CompileAction.run(Unknown Source)
        at org.eclipse.jface.action.Action.runWithEvent(Action.java:881)
        at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:915)
        at
org.eclipse.jface.action.ActionContributionItem.access$500(ActionContributionItem.java:47)
        at
org.eclipse.jface.action.ActionContributionItem$8.handleEvent(ActionContributionItem.java:824)
        at
org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:82)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:954)
        at
org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2595)
        at
org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2298)
        at
org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1377)
        at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1348)
        at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:254)
        at
org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:141)
        at
org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:96)
        at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:335)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:273)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:129)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
        at org.eclipse.core.launcher.Main.run(Main.java:644)
        at org.eclipse.core.launcher.Main.main(Main.java:628)

Further clicking around results in the NullPointerExceptions.

Comment 3 Jeff Pound 2004-10-12 12:39:27 EDT
Have you configured the preferences for your target server?

Window -> Preferences -> Lomboz -> Server Definitions
Select your target sever from "Server types:" and configure the fields.

If this doesnt help please post specifically which target server you
are using so we can try to reproduce the error.
Comment 4 Graham Leggett 2004-10-12 12:47:31 EDT
Unfortunately Lomboz seems to be in a state of complete brokenness,
which is making it difficult to isolate each problem.

Lomboz it seems contains a JSP editor, but if you try and use it it
complains about not being able to access the XML parser, logging the
following to stdout:

SEVERE: Invalid PUBLIC ID: -//Sun Microsystems, Inc.//DTD Web Application
2.3//EN
Unhandled event loop exception
Reason:
org/w3c/dom/ranges/DocumentRange
Unhandled event loop exception
Reason:
org/w3c/dom/ranges/DocumentRange

It looks like Lomboz depends on a specific version of an XML parser,
but this parser is not installed, implying the dependancies on the
lomboz RPM are broken.

The server is jakarta-tomcat-5.0.18, and has been defined in the
settings you describe.
Comment 5 RHEL Product and Program Management 2007-10-19 15:16:33 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.