Bug 1351118 - upgrade failed for RHEL-7.3 from RHEL-7.2.z
Summary: upgrade failed for RHEL-7.3 from RHEL-7.2.z
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 09:59 UTC by Kaleem
Modified: 2016-11-04 05:55 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:55:35 UTC


Attachments (Terms of Use)
console output and upgrade log snip (7.05 KB, text/plain)
2016-06-29 09:59 UTC, Kaleem
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Kaleem 2016-06-29 09:59:01 UTC
Created attachment 1173735 [details]
console output and upgrade log snip

Description of problem:
upgrade from 7.2.z to 7.3.alpha failed.


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-0.el7.2.alpha1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. On a 7.2.z IPA vm, run upgrade to 7.3 
2. Restart IPA 


Actual results:
IPA restart failed.

Expected results:
IPA restart should be successful.

Additional info:
(1) Please find the attached file for console output and snip of upgrade log.

Comment 1 Petr Vobornik 2016-06-29 10:20:09 UTC
Fraser, have you seen this?

Seems that it fails in ensure_ipa_authority_entry


2016-06-29T09:28:48Z DEBUG The ipa-server-upgrade command failed, exception: RemoteRetrieveError: Non-2xx response from CA REST API: 500.

Comment 2 Petr Vobornik 2016-06-29 10:28:34 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6011

Comment 5 Fraser Tweedale 2016-06-30 11:18:36 UTC
Patch on freeipa-devel@

Comment 6 Petr Vobornik 2016-07-01 09:11:04 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/3691e39a62da5134f911f6a798f79a3a2ae0c025

Comment 8 Nikhil Dehadrai 2016-07-19 07:46:18 UTC
Server version: ipa-server-4.4.0-2.1.el7.x86_64

Verified the bug on the basis of following points:
1. Verified that IPA server is successfully upgraded to latest version of RHEL 7.3 and the IPA -server service is restarted correctly after the upgrade.

2. No error message is observed during the upgrade.

3. Refer the attached console output log.

Thus on the basis of above observations, marking the status of bug to "VERIFIED".

Comment 11 errata-xmlrpc 2016-11-04 05:55:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.