Bug 1351140 - ipa-server-install fails to detect hostname from /etc/hosts file
Summary: ipa-server-install fails to detect hostname from /etc/hosts file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 10:46 UTC by Abhijeet Kasurde
Modified: 2016-11-04 05:55 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:55:43 UTC


Attachments (Terms of Use)
ipa-server-install.log (15.26 KB, text/plain)
2016-06-29 10:48 UTC, Abhijeet Kasurde
no flags Details
console.log (10.54 KB, text/plain)
2016-08-24 04:20 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2016-06-29 10:46:49 UTC
Description of problem:
While installing ipa server using following command,

# ipa-server-install --external-ca --setup-dns --forwarder=10.6.6.29 --hostname=server04.testrelm.test -r TESTRELM.TEST -n testrelm.test -p Secret123 -a Secret123 -U -P Secret123

Checking DNS domain testrelm.test, please wait ...
WARNING:
option '-P/--master-password' is deprecated. KDC master password of
sufficient strength is autogenerated during IPA server installation and should
not be set manually.

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host auto-hv-02-guest04.testrelm.test
Checking DNS domain testrelm.test., please wait ...
No usable IP address provided nor resolved.
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
10.6.6.9 server04.testrelm.test server04



Version-Release number of selected component (if applicable):
ipa-server-4.4.0-0.el7.2.alpha1.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Mention hostname with IP in /etc/hosts
2. Install ipa-server without --ip-address parameter

Actual results:
Installation failed.

Expected results:
Installation should resolve hostname from /etc/hosts file and should succeed. 


Additional info:
This command works fine in RHEL 7.2 and below versions.

Comment 1 Abhijeet Kasurde 2016-06-29 10:48 UTC
Created attachment 1173768 [details]
ipa-server-install.log

Comment 2 Petr Vobornik 2016-06-29 11:20:14 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5962

Comment 8 Petr Vobornik 2016-07-13 14:56:42 UTC
this bz was part of rebase

Comment 10 Abhijeet Kasurde 2016-08-24 04:20 UTC
Created attachment 1193465 [details]
console.log

Comment 11 Abhijeet Kasurde 2016-08-24 04:21:05 UTC
Verified using IPA version ::
ipa-server-4.4.0-8.el7.x86_64

Marking BZ as verified.

Comment 13 errata-xmlrpc 2016-11-04 05:55:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.