Bug 1351149 - [abrt] kf5-kinit: qt_message_fatal(): kdeinit5 killed by SIGABRT
Summary: [abrt] kf5-kinit: qt_message_fatal(): kdeinit5 killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1370222
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-kinit
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:803aebcd943dc4c5815e406df83...
Keywords:
: 1424682 1432617 1433142 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 11:11 UTC by Mustafa Muhammad
Modified: 2017-03-16 22:25 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-03-16 12:54:04 UTC


Attachments (Terms of Use)
File: backtrace (29.05 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: cgroup (242 bytes, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: core_backtrace (5.33 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: dso_list (11.47 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: environ (4.49 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: limits (1.29 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: maps (50.60 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: mountinfo (3.52 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: namespaces (102 bytes, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: open_fds (279 bytes, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-06-29 11:12 UTC, Mustafa Muhammad
no flags Details

Description Mustafa Muhammad 2016-06-29 11:11:57 UTC
Version-Release number of selected component:
kf5-kinit-5.23.0-1.fc25

Additional info:
reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        'klauncher [kdeinit5] --fd=8'
crash_function: qt_message_fatal
executable:     /usr/bin/kdeinit5
global_pid:     2007
kernel:         4.7.0-0.rc5.git0.1.fc25.x86_64
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1648
 #3 QMessageLogger::fatal at global/qlogging.cpp:790
 #4 QXcbConnection::QXcbConnection at qxcbconnection.cpp:585
 #5 QXcbIntegration::QXcbIntegration at qxcbintegration.cpp:179
 #6 QXcbIntegrationPlugin::create at qxcbmain.cpp:50
 #7 loadIntegration at kernel/qplatformintegrationfactory.cpp:56
 #8 QPlatformIntegrationFactory::create at kernel/qplatformintegrationfactory.cpp:73
 #9 init_platform at kernel/qguiapplication.cpp:1058
 #10 QGuiApplicationPrivate::createPlatformIntegration at kernel/qguiapplication.cpp:1227
 #11 QGuiApplicationPrivate::createEventDispatcher at kernel/qguiapplication.cpp:1244

Potential duplicate: bug 1167056

Comment 1 Mustafa Muhammad 2016-06-29 11:12:03 UTC
Created attachment 1173787 [details]
File: backtrace

Comment 2 Mustafa Muhammad 2016-06-29 11:12:04 UTC
Created attachment 1173788 [details]
File: cgroup

Comment 3 Mustafa Muhammad 2016-06-29 11:12:06 UTC
Created attachment 1173789 [details]
File: core_backtrace

Comment 4 Mustafa Muhammad 2016-06-29 11:12:08 UTC
Created attachment 1173790 [details]
File: dso_list

Comment 5 Mustafa Muhammad 2016-06-29 11:12:10 UTC
Created attachment 1173791 [details]
File: environ

Comment 6 Mustafa Muhammad 2016-06-29 11:12:12 UTC
Created attachment 1173792 [details]
File: limits

Comment 7 Mustafa Muhammad 2016-06-29 11:12:14 UTC
Created attachment 1173793 [details]
File: maps

Comment 8 Mustafa Muhammad 2016-06-29 11:12:16 UTC
Created attachment 1173794 [details]
File: mountinfo

Comment 9 Mustafa Muhammad 2016-06-29 11:12:17 UTC
Created attachment 1173795 [details]
File: namespaces

Comment 10 Mustafa Muhammad 2016-06-29 11:12:19 UTC
Created attachment 1173796 [details]
File: open_fds

Comment 11 Mustafa Muhammad 2016-06-29 11:12:20 UTC
Created attachment 1173797 [details]
File: proc_pid_status

Comment 12 Mustafa Muhammad 2016-06-29 11:12:22 UTC
Created attachment 1173798 [details]
File: var_log_messages

Comment 13 Jan Kurik 2016-07-26 04:42:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 14 Mustafa Muhammad 2016-10-10 07:36:25 UTC
Similar problem has been detected:

Just logged into the latest wayland plasma session

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/kf5/klauncher --fd=8
crash_function: qt_message_fatal
executable:     /usr/libexec/kf5/klauncher
global_pid:     2091
kernel:         4.8.1-1.fc25.x86_64
package:        kf5-kinit-5.26.0-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         klauncher killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Allan Poulsen 2016-12-21 12:26:16 UTC
Similar problem has been detected:

The same thing as https://bugzilla.redhat.com/show_bug.cgi?id=1406752. This problem is related to this failure.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/kf5/klauncher --fd=8
crash_function: qt_message_fatal
executable:     /usr/libexec/kf5/klauncher
global_pid:     4426
kernel:         4.8.14-300.fc25.x86_64
package:        kf5-kinit-5.27.0-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         klauncher killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 Gerasim 2017-02-18 02:58:51 UTC
*** Bug 1424682 has been marked as a duplicate of this bug. ***

Comment 17 deuzene 2017-03-15 19:30:04 UTC
*** Bug 1432617 has been marked as a duplicate of this bug. ***

Comment 18 Rex Dieter 2017-03-16 12:54:04 UTC
var_log_messages:

... QXcbConnection: Could not connect to display :0

either X server died or xauth was invalidated (bug #1370222).  assuming the latter until there's evidence to the contrary.

*** This bug has been marked as a duplicate of bug 1370222 ***

Comment 19 Gerasim 2017-03-16 22:25:47 UTC
*** Bug 1433142 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.