Bug 1351154 - nfs-ganesha disable doesn't delete nfs-ganesha folder from /var/run/gluster/shared_storage
Summary: nfs-ganesha disable doesn't delete nfs-ganesha folder from /var/run/gluster/s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: 3.8.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1347922 1349398
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 11:21 UTC by Jiffin
Modified: 2016-07-08 14:42 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.8.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1349398
Environment:
Last Closed: 2016-07-08 14:42:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jiffin 2016-06-29 11:21:20 UTC
+++ This bug was initially created as a clone of Bug #1349398 +++

+++ This bug was initially created as a clone of Bug #1347922 +++

Description of problem:

nfs-ganesha disable doesn't delete nfs-ganesha folder from /var/run/gluster/shared_storage

Version-Release number of selected component (if applicable):

nfs-ganesha-2.3.1-8

How reproducible:

Always

Steps to Reproduce:

1. On a already running nfs-ganesha cluster, disable nfs-ganesha using below command:

gluster nfs-ganesha disable

2. Observe that the nfs-ganesha folder, which is being created under /var/run/gluster/shared_storage during nfs-ganesha enable, doesn't get deleted from the path


Actual results:

nfs-ganesha disable doesn't delete nfs-ganesha folder from /var/run/gluster/shared_storage

Expected results:

the nfs-ganesha folder should get deleted from /var/run/gluster/shared_storage once we disable nfs-ganesha on the cluster.

Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-06-18 09:12:34 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Vijay Bellur on 2016-06-23 08:17:31 EDT ---

REVIEW: http://review.gluster.org/14782 (ganesha/scripts : delete nfs-ganesha folder from shared storage during clean up) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-06-23 20:48:42 EDT ---

COMMIT: http://review.gluster.org/14782 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit ec3ea75513347deb95960f49d58fc19478a7ad17
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Thu Jun 23 17:41:09 2016 +0530

    ganesha/scripts : delete nfs-ganesha folder from shared storage during clean up
    
    A directory named "nfs-ganesha" will be created inside shared storage when
    'gluster nfs-ganesha enable' is executed. Similarly this directory should be
    removed when 'gluster nfs-ganesha disable' is executed.
    
    Change-Id: Icc09b32010de07c9809e22aafbb2fd08a5c8252f
    BUG: 1349398
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/14782
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Vijay Bellur 2016-06-29 11:23:27 UTC
REVIEW: http://review.gluster.org/14833 (ganesha/scripts : delete nfs-ganesha folder from shared storage during clean up) posted (#1) for review on release-3.8 by jiffin tony Thottan (jthottan@redhat.com)

Comment 2 Vijay Bellur 2016-07-04 13:28:26 UTC
COMMIT: http://review.gluster.org/14833 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 31de95d5f3b71b4bfd0042e2612fc2ee15f9834c
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Thu Jun 23 17:41:09 2016 +0530

    ganesha/scripts : delete nfs-ganesha folder from shared storage during clean up
    
    A directory named "nfs-ganesha" will be created inside shared storage when
    'gluster nfs-ganesha enable' is executed. Similarly this directory should be
    removed when 'gluster nfs-ganesha disable' is executed.
    
    Upstream reference:
    >Change-Id: Icc09b32010de07c9809e22aafbb2fd08a5c8252f
    >BUG: 1349398
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/14782
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >(cherry picked from commit ec3ea75513347deb95960f49d58fc19478a7ad17)
    
    Change-Id: Icc09b32010de07c9809e22aafbb2fd08a5c8252f
    BUG: 1351154
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/14833
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 3 Niels de Vos 2016-07-08 14:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.1, please open a new bug report.

glusterfs-3.8.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/156
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.