Bug 1351164 - Possible to add Python 3 subpackage?
Possible to add Python 3 subpackage?
Status: CLOSED DUPLICATE of bug 1209685
Product: Fedora
Classification: Fedora
Component: protobuf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lev Shamardin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3
  Show dependency treegraph
 
Reported: 2016-06-29 07:38 EDT by Terje Røsten
Modified: 2016-09-28 02:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-28 02:41:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2016-06-29 07:38:52 EDT
Description of problem:

Protobuf package builds and ships a Python 2 subpackage,
can a Python 3 based subpackage for protobuf also be included?
Comment 1 Dominika Krejčí 2016-08-18 11:10:00 EDT
Hi Lev,

how is it going? Do you need some help? Check out the Python RPM Porting Guide! http://python-rpm-porting.readthedocs.io/en/latest/index.html ;)
Comment 2 Miro Hrončok 2016-09-27 16:53:22 EDT
I'm going to need the Python 3 bindings as a dependency for another package.

When preparing a patch, I've realized that the currently packaged version does not support Python 3 yet. So we also need to upgrade this to a more recent version. I will look at this soon.
Comment 3 Igor Gnatenko 2016-09-28 02:41:36 EDT
It will be part of new release.

*** This bug has been marked as a duplicate of bug 1209685 ***

Note You need to log in before you can comment on or make changes to this bug.