Bug 135121 - rpmmd doesn't work
Summary: rpmmd doesn't work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Connor
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-08 19:38 UTC by Bill Nottingham
Modified: 2014-03-31 01:37 UTC (History)
4 users (show)

Fixed In Version: 4.4.16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 23:51:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2004-10-08 19:38:12 UTC
/etc/sysconfig/rhn/sources has:

rpmmd  wibble file:///usr/local/rawhide/i386/

(or)

rpmmd wibble
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/

up2date -l yields:

# up2date -l
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1249, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 804, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1123, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 62, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 97, in
__findPackagesToUpdate
    plist.addGlobs(self.listOfGlobs)
  File "/usr/share/rhn/up2date_client/packageList.py", line 157, in
addGlobs
    availList = rhnPackageInfo.getAvailablePackageList()
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 219, in
getAvailablePackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 153, in
availablePackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 310, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 20, in
listPackages
    return self.handlers[channel['type']].listPackages(channel,
msgCallback, progressCallback)
KeyError: 'rpmmd'

Comment 1 Jos Vos 2005-03-18 22:55:12 UTC
Probably because registering "rpmmd" in RepoDirectory.py (last lines) is
commented out (this is the case since long, also in FC4t1's up2date it seems :-( ).

Comment 2 Jason Connor 2005-04-14 17:22:06 UTC
Uncommented the rpmmd repo registration and fixed problem with outdated API
Seems to be working with multiple installs and updates from a rpmmd repo

Comment 3 Adrian Likins 2005-04-26 21:34:57 UTC
rpmmd support has been rewritten as "repomd", it now uses the
YumBase api to do this and will use the same config as yum
(aka, /etc/yum.repos.d) if enabled.

4.4.16


Note You need to log in before you can comment on or make changes to this bug.