Bug 1351226 - engine says host is not reachable when trying to add a new host
Summary: engine says host is not reachable when trying to add a new host
Keywords:
Status: CLOSED DUPLICATE of bug 1350763
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-host-deploy
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 13:58 UTC by movciari
Modified: 2016-06-30 11:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-30 11:41:03 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
engine logs (535.00 KB, application/x-gzip)
2016-06-29 13:58 UTC, movciari
no flags Details
vdsm logs (110.76 KB, application/x-gzip)
2016-06-29 13:59 UTC, movciari
no flags Details

Description movciari 2016-06-29 13:58:57 UTC
Created attachment 1173931 [details]
engine logs

Description of problem:
When trying to add a new host to engine, it goes through all stages of host installation, and after "Stage: Termination" it says Host host1 installation failed. Host not reachable." and puts host to "Install Failed" status
I'm sure it's reachable from engine machine, because all stages, like installation of packages, and starting vdsm, passed, and I can still SSH from engine machine to host machine



Version-Release number of selected component (if applicable):
rhevm-3.5.8-0.1.el6ev.noarch
ovirt-host-deploy-1.3.2-1.el6ev.noarch
vdsm-4.16.37-1.el6ev.x86_64

How reproducible:


Steps to Reproduce:
1. add clean machine with VDSM 4.16 to 3.5.8 engine

Actual results:
fails to install

Expected results:
should install

Additional info:

Comment 1 movciari 2016-06-29 13:59:28 UTC
Created attachment 1173932 [details]
vdsm logs

Comment 3 Oved Ourfali 2016-06-30 05:44:50 UTC
Does re-install help?
How often does this reproduce?

Comment 4 Piotr Kliczewski 2016-06-30 06:36:58 UTC
Looking at the logs I see that engine never succeeded to connect to vdsm. have you decided not to reconfigure firewall automatically? If so you need to open 54321 port manually.

I see in the logs this:

2016-06-29 14:20:01 DEBUG otopi.context context.dumpEnvironment:500 ENV NETWORK/iptablesEnable=bool:'False'
2016-06-29 14:20:01 DEBUG otopi.context context.dumpEnvironment:500 ENV NETWORK/iptablesRules=NoneType:'None'

Comment 5 movciari 2016-06-30 08:42:56 UTC
> How often does this reproduce?
I tried to reinstall that host on this setup a few times, and it seems to reproduce all the time on my setup
> have you decided not to reconfigure firewall automatically?
I went with the defaults


This problem seems to be fixed by https://gerrit.ovirt.org/#/c/59948/1/lib/yajsonrpc/__init__.py

Comment 6 Oved Ourfali 2016-06-30 11:41:03 UTC

*** This bug has been marked as a duplicate of bug 1350763 ***


Note You need to log in before you can comment on or make changes to this bug.