Bug 1351254 - Data Processing section doesn't show up in the Dashboard [NEEDINFO]
Summary: Data Processing section doesn't show up in the Dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-puppet-elements
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Linux
medium
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Elise Gafford
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks: 1344562 1358450
TreeView+ depends on / blocked
 
Reported: 2016-06-29 14:23 UTC by Raissa Sarmento
Modified: 2016-08-11 11:33 UTC (History)
16 users (show)

Fixed In Version: openstack-tripleo-puppet-elements-2.0.0-4.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1358450 (view as bug list)
Environment:
Last Closed: 2016-08-11 11:33:55 UTC
Target Upstream Version:
tvignaud: needinfo+
egafford: needinfo? (opavlenk)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Raissa Sarmento 2016-06-29 14:23:27 UTC
Description of problem:
After deploying overcloud using OSPD, Sahara is installed, but the Data Processing section on the Dashboard doesn't show up. 


Steps to Reproduce:
1. Deploy overcloud
2. See Sahara (Data Processing) services are installed
3. Enable sahara services
4. Check dashboard to see Data Processing subsection

Actual results:
Dashboard does not contain Data Processing subsection of Project

Expected results:
The Dashboard should show this section, since Director already installed the Data Processing service

Comment 3 Raissa Sarmento 2016-06-29 15:10:53 UTC
Package versions:
openstack-tripleo-common-2.0.0-6.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-2.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-12.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-6.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-12.el7ost.noarch
python-tripleoclient-2.0.0-1.0.4.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-12.el7ost.noarch

Comment 4 Raissa Sarmento 2016-06-29 15:23:06 UTC
The missing step is that the openstack-sahara-ui package is not installed by OSPD on the controller(s) - after manually installing it, the section shows up.

Comment 6 Keith Basil 2016-07-20 17:36:36 UTC
Elise, can you provide proper release notes to get this documented?

Comment 11 Thierry Vignaud 2016-07-27 12:23:13 UTC
sorry, was in wrong report.
I already applied the patch downstream & the fixed package is already in the errata (as you can see in the "fixed in version" field)

Comment 13 Elise Gafford 2016-08-01 13:34:09 UTC
Hi Ola,

Traditionally, the Sahara team has tested its own features and patches end to end. With the Sahara team starting to introduce minor and bugfix patches into TripleO, though, shall we leave this assigned to you or reassign it to Luigi Toscano on our side?

Thanks,
Elise

Comment 14 Luigi Toscano 2016-08-09 15:10:01 UTC
The package openstack-sahara-ui is installed when the system is deployed (Sahara services are always installed in RH-OSP9).

Verified on:

openstack-puppet-modules-8.1.7-2.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
openstack-tripleo-common-2.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-30.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-30.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-6.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-4.el7ost.noarch
puppet-3.6.2-4.el7sat.noarch
python-tripleoclient-2.0.0-2.el7ost.noarch

openstack-sahara-4.0.1-2.el7ost.noarch
openstack-sahara-api-4.0.1-2.el7ost.noarch
openstack-sahara-common-4.0.1-2.el7ost.noarch
openstack-sahara-engine-4.0.1-2.el7ost.noarch
openstack-sahara-ui-4.0.0-3.el7ost.noarch
python-sahara-4.0.1-2.el7ost.noarch
python-saharaclient-0.13.0-1.el7ost.noarch

Comment 16 errata-xmlrpc 2016-08-11 11:33:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.