Bug 1351285 - Synaptics TouchPad erroneously shown as supporting two-finger scroll
Summary: Synaptics TouchPad erroneously shown as supporting two-finger scroll
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 15:36 UTC by Brandon Nielsen
Modified: 2016-10-06 20:22 UTC (History)
3 users (show)

Fixed In Version: libinput-1.4.2-2.fc24 libinput-1.4.2-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-06 20:22:11 UTC


Attachments (Terms of Use)
evemu-record of two finger scrolling down the TouchPad (20.30 KB, text/plain)
2016-06-29 15:40 UTC, Brandon Nielsen
no flags Details
evemu-record of two finger scrolling up the TouchPad (23.57 KB, text/plain)
2016-06-29 15:41 UTC, Brandon Nielsen
no flags Details
dmesg from HP 8510w (70.91 KB, text/plain)
2016-06-30 01:50 UTC, Brandon Nielsen
no flags Details
ps2emu record of two finger scrolling down the TouchPad (93.80 KB, text/plain)
2016-06-30 01:51 UTC, Brandon Nielsen
no flags Details
ps2emu record of two finger scrolling up the TouchPad (85.12 KB, text/plain)
2016-06-30 01:52 UTC, Brandon Nielsen
no flags Details

Description Brandon Nielsen 2016-06-29 15:36:28 UTC
Description of problem:

Synaptics TouchPad is shown as supporting two-finger scrolling when this is not the case.

Laptop is an HP 8510w.

libinput-list-devices shows the following about the TouchPad:

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event5
Group:            5
Seat:             seat0, default
Size:             54.05x25.33mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none


Version-Release number of selected component (if applicable):

libinput.86_64 - 1.3.3-2
xorg-x11-drv-libinput.x86_64 - 0.16.0-2


How reproducible:

100% of the time


Steps to Reproduce:

1. Boot laptop
2. Ensure 2-finger scrolling is enabled with 'xinput set-prop 10 290 1, 0, 0' where 10 is the id of the TouchPad given by 'xinput list'
3. Attempt to two-finger scroll


Actual results:

No scrolling, cursor sometimes jumps after lifting fingers.


Expected results:

Scrolling.

Comment 1 Brandon Nielsen 2016-06-29 15:40:25 UTC
Created attachment 1174003 [details]
evemu-record of two finger scrolling down the TouchPad

Two fingers placed at the top of the TouchPad, and moved downward.

Comment 2 Brandon Nielsen 2016-06-29 15:41:44 UTC
Created attachment 1174006 [details]
evemu-record of two finger scrolling up the TouchPad

Two fingers placed at the bottom of the TouchPad, and moved upward.

Comment 3 Peter Hutterer 2016-06-29 23:15:10 UTC
ok, this is probably a fw issue. the touchpad announces it has BTN_TOOL_DOUBLETAP but it doesn't appear to ever set it, presumably because it never detects two fingers. You can verify this by running evemu-record | grep BTN_TOOL_DOUBLETAP and see if that ever appears other than in the device description at the start.

if not, this will require a kernel quirk.

Please attach your dmesg and the ps2emu-record output. You can get ps2emu from here: https://github.com/Lyude/ps2emu

Comment 4 Brandon Nielsen 2016-06-30 01:49:20 UTC
(In reply to Peter Hutterer from comment #3)
> ok, this is probably a fw issue. the touchpad announces it has
> BTN_TOOL_DOUBLETAP but it doesn't appear to ever set it, presumably because
> it never detects two fingers. You can verify this by running evemu-record |
> grep BTN_TOOL_DOUBLETAP and see if that ever appears other than in the
> device description at the start.
> 

No matter what variation of fingers I try to scroll with, I never see more than the BTN_TOOL_DOUBLETAP from the initial device description.

Comment 5 Brandon Nielsen 2016-06-30 01:50:10 UTC
Created attachment 1174293 [details]
dmesg from HP 8510w

Comment 6 Brandon Nielsen 2016-06-30 01:51:30 UTC
Created attachment 1174294 [details]
ps2emu record of two finger scrolling down the TouchPad

ps2emu record of two fingers placed at the top of the TouchPad, and moved downward.

Comment 7 Brandon Nielsen 2016-06-30 01:52:28 UTC
Created attachment 1174295 [details]
ps2emu record of two finger scrolling up the TouchPad

ps2emu record of two fingers placed at the top of the TouchPad, and moved upward.

Comment 8 Peter Hutterer 2016-08-25 00:12:25 UTC
Benjamin: BTN_TOOL_DOUBLETAP announced but never set, the device doesn't seem to be capable of detecting two fingers. Are we gonna fix this in the kernel or quirk it in libinput?

Comment 9 Benjamin Tissoires 2016-08-30 07:34:05 UTC
(In reply to Peter Hutterer from comment #8)
> Benjamin: BTN_TOOL_DOUBLETAP announced but never set, the device doesn't
> seem to be capable of detecting two fingers. Are we gonna fix this in the
> kernel or quirk it in libinput?

Not sure we can fix it in the kernel without adding a special case for it. The touchpad announced itself with multifinger, but no advanced gestures. The kernel doesn't initialize the mt slot (which is correct), but still set the double/triple tap bits (correct too). However, the touchpad doesn't seem to forward double/triple tap events in the ps2emu recording.

Given that the solution is to add a quirk for it, I'd rather have this in userspace (especially if xorg-synaptics/xorg-evdev don't care).

Comment 10 Peter Hutterer 2016-08-30 07:57:04 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=15435776

test build, please install, reboot and see if that fixes things, thanks. and by fixing things I mean: the touchpad should not come up as supporting 2 fingers anymore now.

Comment 11 Brandon Nielsen 2016-08-30 21:00:37 UTC
(In reply to Peter Hutterer from comment #10)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=15435776
> 
> test build, please install, reboot and see if that fixes things, thanks. and
> by fixing things I mean: the touchpad should not come up as supporting 2
> fingers anymore now.

Confirmed the touchpad does not come up as supporting 2-finger scrolling with libinput-1.4.2-1.bz1351285 installed.

Resulting libinput-list-devices output for completeness:

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event5
Group:            5
Seat:             seat0, default
Size:             54.05x25.33mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

Comment 12 Fedora Update System 2016-08-31 00:48:20 UTC
libinput-1.4.2-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-772671cc59

Comment 13 Fedora Update System 2016-08-31 01:01:05 UTC
libinput-1.4.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c4c3b886ca

Comment 14 Fedora Update System 2016-08-31 16:23:22 UTC
libinput-1.4.2-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-772671cc59

Comment 15 Fedora Update System 2016-09-02 20:50:40 UTC
libinput-1.4.2-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-09-05 05:15:58 UTC
libinput-1.4.2-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a4afcb5bd7

Comment 17 Fedora Update System 2016-09-05 17:53:33 UTC
libinput-1.4.2-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-09-06 04:47:35 UTC
libinput-1.4.2-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a4afcb5bd7

Comment 19 Fedora Update System 2016-10-06 20:22:11 UTC
libinput-1.4.2-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.