Bug 13513 - best_copy_from_user fail.
Summary: best_copy_from_user fail.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-06 03:44 UTC by owlhuang
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-06 03:44:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description owlhuang 2000-07-06 03:44:17 UTC
I use copy_from_user function in my module.

The kernel rejects to insert the module due to no best_copy_from_user 
symbol exported.  I have checked the /proc/ksyms, there do be 
best_copy_from_user_Rsmpe183bad0 exported.  

I precompiled my source to assembly code and there is best_copy_from_user 
but not best_copy_from_user_Rsmpe183bad0.  So, I 
checked /usr/include/linux/modules-smp/i386_ksyms.ver 
and /usr/include/linux/modules-smp/ksyms.ver, there are no relative 
definition there!!

It works if I add the following lines in i386_ksyms.ver:

#define __ver_best_copy_from_user smpe183bad0
#define best_copy_from_user _set_ver(best_copy_from_user)

Is it a bug?

Enviroment:
RedHat 6.2 with original i386 smp kernel
smp motherboard with one PIII on it.


yours, Dennis

Comment 1 Alan Cox 2000-08-22 16:22:13 UTC
Looks like some kind of module versioning problem yes
We dont have the PIII patches enabled in rawhide so closing this



Note You need to log in before you can comment on or make changes to this bug.