Bug 1351413 - /usr/bin/skyring-setup is not owned by any package
Summary: /usr/bin/skyring-setup is not owned by any package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: build
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Shubhendu Tripathi
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-06-30 03:56 UTC by Ken Dreyer (Red Hat)
Modified: 2016-08-23 19:56 UTC (History)
6 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:56:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 283597 None None None 2016-07-12 04:56:40 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Ken Dreyer (Red Hat) 2016-06-30 03:56:43 UTC
Description of problem:
The rhscon-core packaging symlinks /usr/bin/skyring-setup in %post, rather than doing it in %install.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.29-1.el7scon


How reproducible:
always

Steps to Reproduce:
1. yum install rhscon-core
2. rpm -qf /usr/bin/skyring-setup

Actual results:
/usr/bin/skyring-setup is not owned by any package

Expected results:
rpm prints the NVR of the package that created this file.

Additional info:
I'm guessing that if you "yum remove rhscon-core", /usr/bin/skyring-setup will remain on the system due to this bug.

Comment 2 Shubhendu Tripathi 2016-07-11 12:37:39 UTC
/usr/bin/skyring-setup is a link created to the physical file /usr/share/skyring/setup/skyring-setup.sh owned by rhscon-core.

Do we need this check to be done for links as well??

Comment 3 Ken Dreyer (Red Hat) 2016-07-11 14:58:16 UTC
Yes

Comment 4 Martin Kudlej 2016-07-22 12:01:10 UTC
Script moved into /usr/sbin/skyring-setup and it is owned by rhscon-core
rhscon-core-0.0.35-1.el7scon.x86_64

Comment 6 errata-xmlrpc 2016-08-23 19:56:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.