Bug 135142 - redhat-config-date and ntpd use different driftfile parameters
redhat-config-date and ntpd use different driftfile parameters
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-date (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
RHEL3U7NAK
:
Depends On:
Blocks: 189875
  Show dependency treegraph
 
Reported: 2004-10-08 19:04 EDT by John Kerbawy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0457
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kerbawy 2004-10-08 19:04:43 EDT
Description of problem:
It looks like ntpd was modified a while back to put its driftfile in
/var/lib/ntp/drift instead of the original location of /etc/ntp/drift.
Apparently this change hasn't made into ntp.template from
redhat-config-date.

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Enterprise 3
2. Copy /etc/ntp.conf to /etc/ntp.conf.orig
3. Run redhat-config-date and setup NTP
4. Compare /etc/ntpd.conf with /etc/ntpd.conf.orig

Actual Results:
@@ -54,7 +54,7 @@
 # by creating a temporary in the same directory and then rename()'ing
 # it to the file.
 #
-driftfile /var/lib/ntp/drift
+driftfile /etc/ntp/drift
 broadcastdelay 0.008
 
 #
Comment 1 Nils Philippsen 2005-01-15 05:34:15 EST
fixed in CVS
Comment 2 Nils Philippsen 2005-01-15 05:35:34 EST
just to clarify: that is "CVS contains the same ntp.conf template as current ntp
packages"
Comment 16 Red Hat Bugzilla 2007-06-11 14:54:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0457.html

Note You need to log in before you can comment on or make changes to this bug.