Bug 135151 - member of root group unable to delete files from burn://
Summary: member of root group unable to delete files from burn://
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-09 09:13 UTC by Dams
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 08:04:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dams 2004-10-09 09:13:13 UTC
Description of problem:
This is a major flaw in nautilus-cd-burner UI, you can remove files
you accidentaly dropped in the cd creation window and there is
actually no way to reset/flush the content of this window.

I actually dont see no other solution but to kill the mapping-daemon
and then kill nautilus. Which is totally user-unfriendly.

Version-Release number of selected component:
nautilus-cd-burner(0:2.8.3-3).i386

How reproducible: Always

Steps to Reproduce:
1. Go the the cd creator nautilus window
2. Drop a file in the window
3. Try to remove it
    
Actual Results:  "delete", and even "rename", cant be selected.
The "delete" key wont remove the file.

Additional info: 
It used to work in some old versions. At least on FC1/FC2.

Comment 1 Dams 2004-10-09 09:28:52 UTC
err s/you can remove files/you can't remove files/

Comment 2 Alexander Larsson 2004-10-12 09:07:04 UTC
I don't see this with 2.8.3-4 and gnome-vfs2-2.8.1-7. I'm not sure
what the difference between our system is. Can you try upgrading to
the latest versions of gnome-vfs2 and n-c-b and log in/out and try again?


Comment 3 Dams 2004-10-15 19:45:57 UTC
I currently have : 
gnome-vfs2(0:2.8.2-2).i386
nautilus-cd-burner(0:2.8.3-5).i386

I needed to change kernel so I've rebooted earlier today, so I think i
can say i have no older-versioned gnome daemons currently running. But
 I'm still unable to erase files from the cd-creation nautilus window.

I'll provide any information you need. Just ask. Do you need full
package list (I'm basically running rawhide) ? Or gconf directories
copy, maybe ? i dont think there is private data in them.

Comment 4 Alexander Larsson 2004-10-19 09:41:09 UTC
It seems nautilus thinks you don't have the right to change that file.

Can you try using gnomevfs-ls burn:/// and gnomevfs-rm
burn:///filename to see if the problem is in gnome-vfs or in nautilus.



Comment 5 Dams 2004-10-19 16:59:38 UTC
[anvil@gruyere ~]# gnomevfs-ls burn:///foo.ogg (Regular,
application/ogg)      size 42747269       mode 0644
[anvil@gruyere ~]# gnomevfs-rm burn:///foo.ogg
[anvil@gruyere ~]# gnomevfs-ls burn:///
[anvil@gruyere ~]#

/me votes for a problem in nautilus..

By the way, directories in burn:/// have permissions 0707. Is this..
normal ? (personal umask is 022)

Comment 6 Alexander Larsson 2004-10-20 07:33:51 UTC
burn:/// really doesn't exist. Its a virtual tree, so permissions are
just made up.

Comment 7 Alexander Larsson 2004-10-20 07:39:36 UTC
are you by any chance logged in as root, or as a user that is a member
of the root group?

Comment 8 Alexander Larsson 2004-10-20 07:42:37 UTC
Ah, user being in root group does cause this.

Comment 9 Alexander Larsson 2004-10-20 08:04:23 UTC
Fixed in nautilus-cd-burner-2.8.3-6.

Comment 10 Dams 2004-10-20 11:39:59 UTC
For the record, i confirm my user account is member of the root group.



Note You need to log in before you can comment on or make changes to this bug.