Bug 1351590 - RBD Mirror Crashed on Slave Node "librbd/ObjectMap.cc: 68: FAILED assert(object_no < m_object_map.size())"
Summary: RBD Mirror Crashed on Slave Node "librbd/ObjectMap.cc: 68: FAILED assert(obje...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-30 11:50 UTC by Tanay Ganguly
Modified: 2017-07-30 15:25 UTC (History)
6 users (show)

Fixed In Version: RHEL: ceph-10.2.2-15.el7cp Ubuntu: ceph_10.2.2-11redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:43:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16362 None None None 2016-06-30 22:17:50 UTC
Ceph Project Bug Tracker 16561 None None None 2016-06-30 17:52:43 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Comment 2 Jason Dillaman 2016-06-30 14:39:59 UTC
From the logs, I am unable to determine how rbd-mirror started an image trim operation:

 6: (librbd::operation::C_CopyupObject<librbd::ImageCtx>::send()+0x110) [0x7f7556c7b6c0]

There are 24 instances of this crash over the past day. Per "yum history", it appears the incorrect ceph-debuginfo package (ceph-debuginfo-1:9.2.1-0.el7.x86_64) was installed during all but the most recent crash, so it's quite possible that this is a false backtrace.

Comment 3 Jason Dillaman 2016-06-30 15:28:20 UTC
Need system properly configured to generate core file -- I'll keep gdb attached but it hasn't crashed in several hours whereas before it was crashing nearly every hour. If that backtrace is correct, there should be lots of log messages supporting that fact but there are none.

Comment 11 Tanay Ganguly 2016-07-04 18:26:43 UTC
Unable to reproduce the same in the latest build.
ceph version 10.2.2-15.el7cp

Marking it as Verified.

Comment 13 errata-xmlrpc 2016-08-23 19:43:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.