Bug 1351591 - RBD Mirror Crashed on Slave Node "tools/rbd_mirror/image_sync/ObjectCopyRequest.cc: 240: FAILED assert(m_local_image_ctx->object_map != nullptr)"
Summary: RBD Mirror Crashed on Slave Node "tools/rbd_mirror/image_sync/ObjectCopyReque...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-30 11:50 UTC by Tanay Ganguly
Modified: 2017-07-30 15:30 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-10.2.2-12.el7cp Ubuntu: ceph_10.2.1-10redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:43:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16558 None None None 2016-06-30 14:25:31 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Comment 2 Jason Dillaman 2016-06-30 14:09:10 UTC
Overloaded slave cluster resulted in the loss of the image's exclusive lock during bootstrap:

2016-06-30 10:47:05.775828 7f1c55af6700 -1 librbd::ImageWatcher: 0x7f1b483a2f60 image watch failed: 139755156097920, (107) Transport endpoint is not connected

Comment 7 Tanay Ganguly 2016-07-04 18:26:48 UTC
Unable to reproduce the same in the latest build.
ceph version 10.2.2-15.el7cp

Marking it as Verified.

Comment 9 errata-xmlrpc 2016-08-23 19:43:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.