Bug 135162 - Strange error message when connecting to Bugzilla xml-rpc
Summary: Strange error message when connecting to Bugzilla xml-rpc
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Frontier-RPC (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-09 15:06 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 19:35:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Ertzinger 2004-10-09 15:06:14 UTC
Description of problem:
Executing the following simple perl script:

perl -e 'use Frontier::Client; $client=Frontier::Client->new("url" =>
"https://bugzilla.redhat.com/bugzilla/xmlrpc.cgi");$client->call("bugzilla.getBug",
"123456", "foo@bar.org", "foo");'

Perl responds with the following error:

syntax error at line 1, column 0, byte 0 at
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi/XML/Parser.pm
line 187

Whatever the cause of the error, no syntax error should occur.

Version-Release number of selected component (if applicable):
perl-Frontier-RPC-0.06-38

How reproducible:
Always


Steps to Reproduce:
1. execute the perl snippet above
2.
3.
  
Actual results:
Syntax error message


Expected results:
Sensible error handling, if the request was invalid somehow


Additional info:

Comment 1 Warren Togami 2005-05-17 23:47:03 UTC
IIRC Bugzilla XML-RPC is currently broken on the server side?  Anyone know the
details?


Comment 2 Ville Skyttä 2006-02-26 15:28:52 UTC
Seems to work properly now.


Note You need to log in before you can comment on or make changes to this bug.