Fedora Account System
Red Hat Associate
Red Hat Customer
Heketi does not give any warning before deleting the db volume. It will crash the running container. [kubeexec] DEBUG 2016/06/30 10:28:41 /src/github.com/heketi/heketi/executors/kubeexec/kubeexec.go:301: Host: glusterfs-dc-dhcp43-36.lab.eng.blr.redhat.com-1-oq6hx Command: sudo sed -i.save '/brick_9bf1613ebb7ff4e217f5e3c702af5992/d' /var/lib/heketi/fstab Result: unexpected fault address 0x7ff35a90f000 fatal error: fault [signal 0x7 code=0x2 addr=0x7ff35a90f000 pc=0x639827]
upstream issue https://github.com/heketi/heketi/issues/403
heketi-cli volume delete 2301722cb8681192ce07ec92825e0a9b Error: Cannot delete volume containing the Heketi database logs: [negroni] Started DELETE /volumes/2301722cb8681192ce07ec92825e0a9b [negroni] Completed 409 Conflict in 341.099µs Verified from backend too.
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2016-1498.html