Bug 135168 - tar give waring when reading from a pipe
Summary: tar give waring when reading from a pipe
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tar   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-09 17:48 UTC by Fred Romelfanger
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 13:21:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fred Romelfanger 2004-10-09 17:48:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
When piping the output from zcat into tar I regularily get what
appears to be an error about a short read.  I didn't get these
with WS3 or core2.  I was wondering if it might just be a debug
message that was left behind in the code.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use zcat on a compressed tar file and pipe to tar -tf - or -xf -
2.
3.
    

Actual Results:  zcat linux* | tar -tf -
./
./COMMON.TAR
./INSTALL
./README
./LICREAD.TXT
./LINUXRDR.TAR
tar: Read 8192 bytes from -

Expected Results:  zcat linux* | tar -tf -
./
./COMMON.TAR
./INSTALL
./README
./LICREAD.TXT
./LINUXRDR.TAR


Additional info:

Comment 1 Peter Vrabec 2004-10-15 08:48:03 UTC
what's your Version & Release of tar, gzip.


Comment 2 Fred Romelfanger 2004-10-15 19:25:06 UTC
The ones that come with RHEL 4.0 beta:
tar-1.14-2
gzip-1.3.3-13


Comment 3 Peter Vrabec 2004-10-18 11:36:43 UTC
I can't reproduce this error. 
Try upgrade tar to tar-1.14-4.



Note You need to log in before you can comment on or make changes to this bug.