Bug 1351698 - nvml FTBFS on aarch64 epel7
Summary: nvml FTBFS on aarch64 epel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nvml
Version: epel7
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Krzysztof Czurylo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64 ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2016-06-30 15:25 UTC by D. Marlin
Modified: 2016-07-03 14:18 UTC (History)
1 user (show)

Fixed In Version: nvml-1.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-03 14:18:33 UTC
Type: Bug


Attachments (Terms of Use)

Description D. Marlin 2016-06-30 15:25:15 UTC
Description of problem:

nvml fails to build from source for Fedora EPEL7 on RHELSA-7.2.


Version-Release number of selected component (if applicable):

nvml-1.0-2.el7


How reproducible:

consistently


Steps to Reproduce:
1.  On a RHELSA-7.2 host:
    mock -r epel-7-aarch64 nvml-1.0-2.el7.src.rpm
2.
3.

Actual results:

Fails to build with the following error:

cc -MD -c -o ../nondebug/libpmem/cpu.o -std=gnu99 -Wall -Werror -Wmissing-prototypes -Wpointer-arith -Wunused-macros -Wmissing-field-initializers -Wsign-conversion -Wsign-compare -Wconversion -pthread -fno-common -DSRCVERSION=\"\" -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches    -DNO_LIBPTHREAD -I../include -I../common/ -fPIC ../common/cpu.c
pmem.c:206:23: fatal error: xmmintrin.h: No such file or directory
 #include <xmmintrin.h>
                       ^
compilation terminated.
../common/cpu.c:56:0: error: macro "EAX_IDX" is not used [-Werror=unused-macros]
 #define EAX_IDX 0
 ^
cc1: all warnings being treated as errors
make[2]: *** [../nondebug/libpmem/cpu.o] Error 1


Expected results:

builds without errors, or excludes AArch64 as unsupported.


Additional info:

According to the spec file, this _only_ builds for x86_64:

  # Due to dependency on xmmintrin.h and some inline assembly, it can be
  # compiled only for x86_64 at the moment.

Other architectures are excluded:

  ExcludeArch:    %{ix86}
  ExcludeArch:    %{arm}
  ExcludeArch:    s390x
  ExcludeArch:    ppc ppc64 ppc64le

Would it be simpler to just make this package ExclusiveArch x86_64?  If not, please add aarch64 to the list of 'ExcludeArch', until/unless AArch64 support is added.

Comment 1 Fedora Update System 2016-07-01 02:52:29 UTC
nvml-1.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cbcf16b270

Comment 2 D. Marlin 2016-07-01 18:57:05 UTC
Tested building nvml-1.0-3.el7 using mock on AArch64:

Start: rpmbuild nvml-1.0-3.el7.src.rpm
error: Architecture is not included: aarch64

Works as expected.

Comment 3 Fedora Update System 2016-07-02 20:20:58 UTC
nvml-1.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cbcf16b270

Comment 4 Fedora Update System 2016-07-03 14:18:31 UTC
nvml-1.0-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.