Bug 1351748 - Gujarati & Hindi itrans method fails to perform cut, copy, paste & undo using 'ctrl' key sequences.
Summary: Gujarati & Hindi itrans method fails to perform cut, copy, paste & undo using...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-30 17:46 UTC by Nirmal Pathak
Modified: 2016-08-23 15:22 UTC (History)
9 users (show)

Fixed In Version: ibus-typing-booster-1.4.6-1.fc24 ibus-typing-booster-1.4.8-1.fc24 ibus-typing-booster-1.5.0-1.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1249875
Environment:
Last Closed: 2016-08-23 15:22:15 UTC
Type: Bug


Attachments (Terms of Use)
0001-Pass-modifier-key-combinations-through-if-there-is-n.patch (3.66 KB, patch)
2016-07-01 15:20 UTC, Mike FABIAN
no flags Details | Diff
F24 Screenshot with ibus-typing-booster test package. (527.94 KB, image/png)
2016-07-14 17:26 UTC, Nirmal Pathak
no flags Details
0001-Commit-pre-dit-if-modifier-keys-without-transliterat.patch (6.86 KB, patch)
2016-07-16 19:58 UTC, Mike FABIAN
no flags Details | Diff
0001-Commit-pre-dit-if-modifier-keys-without-transliterat.patch (6.86 KB, patch)
2016-07-16 20:05 UTC, Mike FABIAN
no flags Details | Diff
0001-Commit-pre-dit-if-modifier-keys-without-transliterat.patch (6.87 KB, patch)
2016-07-16 20:16 UTC, Mike FABIAN
no flags Details | Diff

Description Nirmal Pathak 2016-06-30 17:46:41 UTC
Description of problem:
The Gujarati & Hindi itrans method fails to perform cut, copy, paste & undo using 'ctrl' key sequences. 

Version-Release number of selected component (if applicable):
m17n-db-1.7.0-7.fc24


How reproducible:
Type in Gujarati or Hindi language using ibus typing booster itrans method.


Steps to Reproduce:
1. Select Gujarati-IN (Hunspell) or Hindi-IN (Hunspell) method in as input source.
2. Open gedit & press keys "Ctrl+x" for cut, "Ctrl+c" for copy, "Ctrl+v" for paste & "Ctrl+z" for undo.

Actual results:
Prints C-x for "Ctrl+x" key sequence.
Prints C-c for "Ctrl+c" key sequence.
Prints C-v for "Ctrl+v" key sequence.
Prints C-z for "Ctrl+z" key sequence.

Expected results:
"Ctrl+x" should cut the selected text or do nothing if no text is selected for cut.
"Ctrl+c" should copy the selected text or do nothing if no text is selected for copy.
"Ctrl+v" should paste the cut or copied text.
"Ctrl+z" should undo last action performed.

Additional info:

Comment 1 Parag Nemade 2016-07-01 06:56:54 UTC
you are actually using ibus-typing-booster when you select "*(Hunspell)*" input source. 

Mike,
   Can you confirm if this is a bug in i-t-b?

Comment 2 Mike FABIAN 2016-07-01 15:20:08 UTC
Created attachment 1174966 [details]
0001-Pass-modifier-key-combinations-through-if-there-is-n.patch

Tentative patch to fix the problem

Comment 3 Fedora Update System 2016-07-04 06:26:01 UTC
ibus-typing-booster-1.4.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-10ef6e096c

Comment 4 Fedora Update System 2016-07-04 06:26:33 UTC
ibus-typing-booster-1.4.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8a1d536c2

Comment 5 Fedora Update System 2016-07-04 06:27:01 UTC
ibus-typing-booster-1.4.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-55ce933247

Comment 6 Fedora Update System 2016-07-05 08:53:17 UTC
ibus-typing-booster-1.4.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-55ce933247

Comment 7 Fedora Update System 2016-07-05 15:22:15 UTC
ibus-typing-booster-1.4.6-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-10ef6e096c

Comment 8 Fedora Update System 2016-07-05 15:24:21 UTC
ibus-typing-booster-1.4.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8a1d536c2

Comment 9 Fedora Update System 2016-07-10 05:55:14 UTC
ibus-typing-booster-1.4.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-07-11 14:56:22 UTC
ibus-typing-booster-1.4.7-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4dff7802ff

Comment 11 Fedora Update System 2016-07-11 14:57:18 UTC
ibus-typing-booster-1.4.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-64cb2a9190

Comment 12 Fedora Update System 2016-07-12 03:26:51 UTC
ibus-typing-booster-1.4.7-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4dff7802ff

Comment 13 Fedora Update System 2016-07-12 03:54:28 UTC
ibus-typing-booster-1.4.7-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-64cb2a9190

Comment 14 Nirmal Pathak 2016-07-14 17:26:52 UTC
Created attachment 1179914 [details]
F24 Screenshot with ibus-typing-booster test package.

Seems like the issue is still not fixed. Check the attached screenshot.

I have installed ibus-typing-booster-1.4.7-1.fc24 package from test repository.

Am I missing something?

Comment 15 Mike FABIAN 2016-07-16 04:10:09 UTC
Nirmal Pathak> still I am getting strange behaviour for 'Ctrl+*'
Nirmal Pathak> If I dont leave space after letter it print C-*
Nirmal Pathak> हैC-a

Comment 16 Mike FABIAN 2016-07-16 19:58:07 UTC
Created attachment 1180541 [details]
0001-Commit-pre-dit-if-modifier-keys-without-transliterat.patch

Comment 17 Mike FABIAN 2016-07-16 20:05:13 UTC
Created attachment 1180542 [details]
0001-Commit-pre-dit-if-modifier-keys-without-transliterat.patch

Solve this bug in a better way, for the modifier key combinations
which do not have a transliteration, pass them through not only when
the preëdit is empty, if the preëdit is non-empty, commit the preëdit
and then pass the modifier key combination through.

Comment 18 Mike FABIAN 2016-07-16 20:16:48 UTC
Created attachment 1180568 [details]
0001-Commit-pre-dit-if-modifier-keys-without-transliterat.patch

The previous patch contained a typo.

Comment 19 Nirmal Pathak 2016-07-17 11:57:06 UTC
I tested the patch & it is working fine for me.

Thanks!

Comment 20 Fedora Update System 2016-07-18 04:19:56 UTC
ibus-typing-booster-1.4.8-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-52131892ac

Comment 21 Fedora Update System 2016-07-18 04:20:46 UTC
ibus-typing-booster-1.4.8-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dfa7430438

Comment 22 Fedora Update System 2016-07-18 04:21:19 UTC
ibus-typing-booster-1.4.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-068080a508

Comment 23 Fedora Update System 2016-07-18 21:52:37 UTC
ibus-typing-booster-1.4.8-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-52131892ac

Comment 24 Fedora Update System 2016-07-18 22:24:13 UTC
ibus-typing-booster-1.4.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dfa7430438

Comment 25 Fedora Update System 2016-07-18 22:25:47 UTC
ibus-typing-booster-1.4.8-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-068080a508

Comment 26 Fedora Update System 2016-07-22 18:22:18 UTC
ibus-typing-booster-1.4.8-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2016-08-12 12:56:46 UTC
ibus-typing-booster-1.5.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5d93a9b45

Comment 28 Fedora Update System 2016-08-12 20:51:47 UTC
ibus-typing-booster-1.5.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5d93a9b45

Comment 29 Fedora Update System 2016-08-23 15:22:05 UTC
ibus-typing-booster-1.5.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.