Bug 1351771 - SELinux denies setrlimit for zabbix-agent on F24
SELinux denies setrlimit for zabbix-agent on F24
Status: CLOSED DUPLICATE of bug 1349998
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-30 15:17 EDT by Erik Logtenberg
Modified: 2016-08-20 12:02 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-20 12:02:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Logtenberg 2016-06-30 15:17:08 EDT
Description of problem:

When starting zabbix-agent on Fedora 24, an SELinux error happens:

un 30 21:12:13 zabbix_agentd[1474]: Starting Zabbix Agent [hostname]. Zabbix 3.0.1 (revision 58734).
jun 30 21:12:13 zabbix_agentd[1474]: Press Ctrl+C to exit.
jun 30 21:12:13 audit[1474]: AVC avc:  denied  { setrlimit } for  pid=1474 comm="zabbix_agentd" scontext=system_u:system_r:zabbix_agent_t:s0 tcontext=system_u:system_r:zabbix_agent_t:s0 tclass=process permissive=0
jun 30 21:12:13 systemd[1]: zabbix-agent.service: Main process exited, code=exited, status=1/FAILURE
jun 30 21:12:13 systemd[1]: zabbix-agent.service: Unit entered failed state.

Version-Release number of selected component (if applicable):

zabbix-agent-3.0.1-0.fc24.x86_64

Zabbix agent runs fine on Fedora 23, it just fails with 24.

How reproducible:
100%
Comment 1 Erik Logtenberg 2016-07-07 16:18:52 EDT
Any additional information I could provide to help fix the issue?

Just to be clear, this bug causes Zabbix to not work at all with Fedora 24. It's kind of a big issue for ppl that use Zabbix for monitoring their stuff, basically blocking the upgrade to Fedora 24 for them.
Comment 2 Erik Logtenberg 2016-08-20 12:02:04 EDT

*** This bug has been marked as a duplicate of bug 1349998 ***

Note You need to log in before you can comment on or make changes to this bug.