Bug 13518 - warning: setsockopt(PACKET_RX_RING): Protocol not available
Summary: warning: setsockopt(PACKET_RX_RING): Protocol not available
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-06 11:07 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 15:02:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-07-06 11:07:42 UTC
Tcpdump gives a warning when running it:

setsockopt(PACKET_RX_RING): Protocol not available

This isn't aesthetically pleasing ;)

Comment 1 Pekka Savola 2000-07-10 19:30:28 UTC
I tracked this to libpcap's pcap_open_live before figuring out this was
just another compile issue.

'rpm --rebuild tcpdump*.src.rpm' fixes the problem.


Comment 2 Jeff Johnson 2000-07-12 04:08:01 UTC
This should be fixed by tcpdump-3.4-22 rebuild.

Comment 3 Pekka Savola 2000-07-27 12:08:54 UTC
This bug resurfaced in beta5 / wasn't fixed. :-(


Comment 4 Tim Waugh 2000-07-27 13:47:19 UTC
tcpdump-3.4-26 works fine here: can you check that's what you have?

Comment 5 Tim Waugh 2000-07-27 13:49:00 UTC
Sorry, my mistake; a rebuilt 3.4-26 works, but the binary package was still
faulty.

Comment 6 Pekka Savola 2000-07-31 20:44:32 UTC
Upped the priority and severity.

IMO this isn't something we want to see in Winston final.



Comment 7 Jeff Johnson 2000-08-04 20:47:40 UTC
This smells like Yet Another Trip through the build system with final kernel
headers should
fix. Please reopen if tcpdump-3.4-27 still has a problem.

Comment 8 Pekka Savola 2000-08-10 15:09:47 UTC
This happens in RC1 too :-(

Comment 9 Jeff Johnson 2000-08-11 15:02:19 UTC
Ahh, the problem is compiling *with* 2.4 headers. Error message removed in
tcpdump-2.4-28.


Note You need to log in before you can comment on or make changes to this bug.