Bug 1351807 - ipa-nis-manage config.get_dn missing
Summary: ipa-nis-manage config.get_dn missing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-30 23:22 UTC by Scott Poore
Modified: 2016-11-04 05:56 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:56:04 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Scott Poore 2016-06-30 23:22:11 UTC
Description of problem:

When I run ipa-nis-manage to enable the NIS plugin for IPA, I only see this output:

config.get_dn()

And from what I can tell, it has not enabled NIS services.

If I run with debug, I do see a traceback showing:

ipa         : DEBUG      File "/usr/lib/python2.7/site-packages/ipaserver/install/installutils.py", line 720, in run_script
    return_value = main_function()

  File "/usr/sbin/ipa-nis-manage", line 135, in main
    compat = get_entry(compat_dn, conn)

  File "/usr/sbin/ipa-nis-manage", line 81, in get_entry
    entry = conn.get_entry(dn)

  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 1470, in get_entry
    size_limit=size_limit

  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 1294, in get_entries
    base_dn=base_dn, scope=scope, filter=filter, attrs_list=attrs_list)

  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 1339, in find_entries
    time_limit = self.time_limit

  File "/usr/lib/python2.7/site-packages/ipaserver/plugins/ldap2.py", line 84, in time_limit
    return float(self.get_ipa_config().single_value.get(

  File "/usr/lib/python2.7/site-packages/ipaserver/plugins/ldap2.py", line 225, in get_ipa_config
    dn = self.api.Object.config.get_dn()

  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 1253, in get_dn
    raise NotImplementedError('%s.get_dn()' % self.name)

ipa         : DEBUG    The ipa-nis-manage command failed, exception: NotImplementedError: config.get_dn()


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-0.el7.2.alpha1.x86_64

How reproducible:
Unknown

Steps to Reproduce:
1.  ipa-server-install
2.  ipa-nis-manage enable
3.  ypcat -d $domain -h $(hostname)

Actual results:
output as mentioned above and does not seem to enable NIS.


Expected results:
enables NIS as expected.

Additional info:

Comment 3 Petr Vobornik 2016-07-01 14:39:57 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6027

Comment 4 Sudhir Menon 2016-07-07 07:38:41 UTC
The same is seen for ipa-compat-manage enable

[root@server ~]# echo labs_pwd|ipa-compat-manage enable
Directory Manager password: 
config.get_dn()

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: nisint_ipamaster_integration_setup_nis_listener: Enable the IPA NIS Listener
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [  BEGIN   ] :: Running 'echo Secret123|ipa-compat-manage enable'
Directory Manager password: config.get_dn()
:: [   FAIL   ] :: Command 'echo Secret123|ipa-compat-manage enable' (Expected 0,2, got 1)

Comment 5 Petr Vobornik 2016-07-12 08:54:12 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/c5cc79f1ad2ef1eb81ad3d9cea2882a7ae1825b2

Comment 7 Scott Poore 2016-07-14 22:13:00 UTC
Verified.

Version ::

ipa-server-4.4.0-2.1.el7.x86_64

Results ::

[root@rhel7-1 ~]# ipa-nis-manage enable
Directory Manager password: 

Enabling plugin
This setting will not take effect until you restart Directory Server.
The rpcbind service may need to be started.

[root@rhel7-1 ~]# service rpcbind restart
Redirecting to /bin/systemctl restart  rpcbind.service

[root@rhel7-1 ~]# systemctl restart dirsrv@EXAMPLE-COM.service

[root@rhel7-1 ~]# ypcat -d example.com -h $(hostname) passwd
admin:*:137000000:137000000:Administrator:/home/admin:/bin/bash

[root@rhel7-1 ~]#

Comment 9 errata-xmlrpc 2016-11-04 05:56:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.