Bug 1351896 - [IntService_public_281] Unable to throttling logs in Fluentd
Summary: [IntService_public_281] Unable to throttling logs in Fluentd
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: chunchen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-01 07:20 UTC by Xia Zhao
Modified: 2016-09-30 02:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-10 21:23:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Xia Zhao 2016-07-01 07:20:54 UTC
Description of problem:
In 3.3.0 images the fluentd is deployed by daemonset instead of dc, so the way to pass throttling settings into fluentd pod is broken since not able to mount the created secret to Fluentd container:
https://github.com/openshift/origin-aggregated-logging#throttling-logs-in-fluentd

Version-Release number of selected component (if applicable):
openshift3/logging-curator      3.3.0     0f4e933a812a
openshift3/logging-elasticsearch      3.3.0     b7051c8b66d3
openshift3/logging-kibana      3.3.0     32d276bb46ae
openshift3/logging-fluentd      3.3.0     0de35fb6abaa
openshift3/logging-auth-proxy      3.3.0     aaa3c8315877
openshift3/logging-deployer      3.3.0     000cdaaa18ea

How reproducible:
Always

Steps to Reproduce:
1. Refer to part "Description of problem"
2.
3.

Actual results:

Expected results:

Additional info:

Comment 1 Luke Meyer 2016-07-01 16:21:05 UTC
You are right. Not only should the docs be amended to point to the daemonset instead of the deploymentconfig, but because daemonsets can't be modified, the directions have to indicate deleting the DS and re-creating it with a patch. I'll work on this.

Comment 2 Xia Zhao 2016-07-27 10:15:39 UTC
I see with latest logging images on brew registry, the fluentd configmap exists, however, the verification of throttling log effect was blocked by kibana UI not accessible, which is described here: https://bugzilla.redhat.com/show_bug.cgi?id=1360675

Will keep monitoring it. In the mean time, please feel free to set this ON_QA if the development work is considered to be done.

Comment 3 Luke Meyer 2016-08-01 20:52:44 UTC
Not sure if https://bugzilla.redhat.com/show_bug.cgi?id=1360675#c12 helps you but if you can get past Kibana, this should be fixed.

Comment 4 Xia Zhao 2016-08-02 10:31:08 UTC
Checked on OSE v3.3.0.13 with latest 3.3.0 images:
1. Able to put throttling settings into configmap/logging-fluentd
2. Throttling settings can be delivered to fluentd container successfully
3. Throttling settings worked (identified from Kibana UI)

Set this to verified.


Note You need to log in before you can comment on or make changes to this bug.