Bug 1351918 - ipa-server-install fails with No usable IP address provided nor resolved.
Summary: ipa-server-install fails with No usable IP address provided nor resolved.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-01 07:49 UTC by Jan Pazdziora
Modified: 2016-11-04 05:56 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:56:08 UTC


Attachments (Terms of Use)
evidence (1.47 KB, text/plain)
2016-09-16 07:05 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Pazdziora 2016-07-01 07:49:56 UTC
Description of problem:

When configuring IPA server on a machine with custom hostname, for example because the server will be base of new identity of new domain, ipa-server-install fails with

The IPA server requires an administrative user, named 'admin'.
This user is a regular system account used for IPA server administration.

IPA admin password: 
Password (confirm): 

Checking DNS domain example.test., please wait ...
Enter the IP address to use, or press Enter to finish.
Please provide the IP address to be used for this host name: 
No usable IP address provided nor resolved.
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

Version-Release number of selected component (if applicable):

ipa-server-4.4.0-0.el7.2.alpha1.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Get IP address of the current host (say 10.16.46.37).
2. Run hostname ipa.example.test
3. Runecho 10.16.46.37 ipa.example.test >> /etc/hosts
4. Run ping ipa.example.test and verify that it's resolvable and reachable.
5. Run ipa-server-install, confirm that you want to use example.test domain.

Actual results:

Checking DNS domain example.test., please wait ...
Enter the IP address to use, or press Enter to finish.
Please provide the IP address to be used for this host name: 
No usable IP address provided nor resolved.
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

The logfile ends with

2016-07-01T07:15:53Z DEBUG session_auth_duration: 0:20:00
2016-07-01T07:15:54Z DEBUG Mounting ipaserver.rpcserver.jsonserver_kerb() at '/json'
2016-07-01T07:15:54Z DEBUG session_auth_duration: 0:20:00
2016-07-01T07:15:54Z DEBUG Loading Index file from '/var/lib/ipa/sysrestore/sysrestore.index'
2016-07-01T07:15:54Z INFO Checking DNS domain example.test., please wait ...
2016-07-01T07:15:54Z DEBUG The DNS query name does not exist: ipa.example.test.
2016-07-01T07:16:04Z DEBUG   File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 171, in execute
    return_value = self.run()
  File "/usr/lib/python2.7/site-packages/ipapython/install/cli.py", line 318, in run
    cfgr.run()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 308, in run
    self.validate()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 317, in validate
    for nothing in self._validator():
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 372, in __runner
    self._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 394, in _handle_exception
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 362, in __runner
    step()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 359, in <lambda>
    step = lambda: next(self.__gen)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
    value = gen.send(prev_value)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 564, in _configure
    next(validator)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 372, in __runner
    self._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 449, in _handle_exception
    self.__parent._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 394, in _handle_exception
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 446, in _handle_exception
    super(ComponentBase, self)._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 394, in _handle_exception
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 362, in __runner
    step()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 359, in <lambda>
    step = lambda: next(self.__gen)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
    value = gen.send(prev_value)
  File "/usr/lib/python2.7/site-packages/ipapython/install/common.py", line 63, in _install
    for nothing in self._installer(self.parent):
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 1348, in main
    install_check(self)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 264, in decorated
    func(installer)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 603, in install_check
    dns.install_check(False, api, False, options, host_name)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/dns.py", line 260, in install_check
    True, options.ip_addresses)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/installutils.py", line 504, in get_server_ip_address
    sys.exit(1)

2016-07-01T07:16:04Z DEBUG The ipa-server-install command failed, exception: SystemExit: 1
2016-07-01T07:16:04Z ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

Expected results:

No error -- the hostname is clear and /etc/hosts makes it resolvable.

Additional info:

This breaks IPA in containers.

Comment 3 Petr Vobornik 2016-07-01 14:25:16 UTC
Can you reproduce even with ipa-4.4.0-1.el7?

Comment 4 Jan Pazdziora 2016-07-08 08:39:18 UTC
(In reply to Petr Vobornik from comment #3)
> Can you reproduce even with ipa-4.4.0-1.el7?

The problem no longer seems to be present with that build. Thank you.

Comment 6 Pavel Picka 2016-09-16 07:05:50 UTC
Created attachment 1201547 [details]
evidence

Verified

4.4.0-11

Comment 8 errata-xmlrpc 2016-11-04 05:56:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.