Bug 135196 - Yum 2.1.x always creates unneeded directory "headers"
Yum 2.1.x always creates unneeded directory "headers"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-09 20:46 EDT by Robert Scheck
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 21:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-10-09 20:46:15 EDT
Description of problem:
Yum 2.1.x always creates the unneeded directory "headers" in 
/var/cache/yum/*repo*/. I think, the "headers" directory was needed 
in < 2.1.x where *.hdr was used...

Version-Release number of selected component (if applicable):
yum-2.1.6-1

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. cd /var/cache/yum/base
2. rm -rf headers
3. file headers
   -> headers: cannot open (headers)
4. yum list
   -> [lots of stuff]
5. file headers
   -> headers: directory
  
Actual results:
The "headers" directory is always created.

Expected results:
No "headers" directory should be created.
Comment 1 Seth Vidal 2004-10-09 21:36:04 EDT
The headers dir is needed b/c it downloads the rpm header of packages
it is depsolving for. So the headers dir does need to be created.

I have a plan to get rid of that but it will take some more work.

But for right now it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.